Bug 190299 - kernel oplock problem
kernel oplock problem
Status: CLOSED DUPLICATE of bug 190298
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-30 14:17 EDT by Mark Orenstein
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-06 20:23:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Orenstein 2006-04-30 14:17:23 EDT
Description of problem:

According to Jeremy of the samba team, it is most likely that kernel oplocks 
is broken in the Fedora kernel.  Below is the samba list correspondence.

> On Fri, Apr 28, 2006 at 10:12:05AM -0400, mrosamba@eastgranby.k12.ct.us
> wrote:
>> > On Mon, Apr 24, 2006 at 05:14:14PM -0400,
>> mrosamba@eastgranby.k12.ct.us
>> > wrote:
>> >> I recently upgraded from samba 3.0.10-1.fc3 to 3.0.21b-2 running on
>> FC5.
>> >> Today was the first day of a typing class which uses the network
>> version
>> >> of Mavis Beacon Typing which depends on file sharing.
>> >>
>> >> The users are hanging and then getting an error message during
>> logging
>> >> into the product.  In /var/log/message, I can see the following
>> message
>> >> for each user similar to:
>> >>
>> >>
>> >> [2006/04/24 09:45:24.177906, 0]
>> >> smbd/oplock.c:oplock_timeout_handler(375)
>> >>   Oplock break failed for file mavis/Mavis15EEVNet/Mav15UserData/Ali
>> >> Johnson.rec -- replying anyway
>> >>
>> >> Each user has a different filename for the above message.
>> >>
>> >> Below is the smb.conf share.  Note the force user.
>> >
>> > I would suggest upgrading to 3.0.22 as there were some fixes
>> > in this area.
>> >
>> > Jeremy.
>> >
>> Hi Jeremy,
>>
>> Last night I updated to Version 3.0.22-1.fc5.  Kernel is
>> 2.6.15-1.2054_FC5.
>> I reenabled oplocks on the mavis share and when the class tried to
>> execute
>> the Mavis typing program, it again locked up.
>>
>> Based on Leonid Zeitlin's note in a similar thread, I then disabled
>> kernel
>> oplocks and had the class try again.  They were all able to get in with
>> no
>> oplock errors on the log.
>>
>> The only software accessing these files is samba so I question whether
>> it
>> is a kernel problem.  Also, with kernel oplocks = no, the oplocks on
>> logon.bat have disappeared.
>
> No, it is a kernel problem - Samba is about the only application
> that *uses* the kernel lease mechanism so it's not suprising that
> only we notice. I'm guessing FC5 has a bug here.
>
> Jeremy.
>



Version-Release number of selected component (if applicable):

see above

How reproducible:

Requires several users of samba logging into a network share.  Another user 
has reported a similar problem to the samba mailing list.


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Dave Jones 2006-05-06 20:23:25 EDT

*** This bug has been marked as a duplicate of 190298 ***

Note You need to log in before you can comment on or make changes to this bug.