Bug 190302 - Gnome crashes after customization
Gnome crashes after customization
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-session (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-30 16:24 EDT by stephane ploix
Modified: 2008-03-18 14:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-18 14:33:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description stephane ploix 2006-04-30 16:24:16 EDT
Description of problem:
Gnome cannot opened a session after user have modified its graphical environment
(for instance icon size and toolbar transparency).


Version-Release number of selected component (if applicable):
Version are: gnome-session-2.14.0-1 & control-center-1:2.14.0-1
After full update (using yum), problem remains. Versions are:
gnome-session-2.14.1-1 & control-center-1:2.14.1-1

How reproducible:
Fully reproductible on this pc.

Steps to Reproduce:
1- Install fc5 from installation DVD on a i386 (hdd are formatted)
2- Create a account
3- open a gnome session
4- modify the icon size of the upper toolbar (let's say 44) and make toolbar
transparent
5- log off
6- log in again and gnome crashes: it is no more possible to login. But it is
still possible to start KDE or xfce sessions
  
Actual results:
I have installed fc5 on a laptop with the libraries: it works properly!
I have recorded the error message (see attachment): "couldn't connect to session
bus: failed to connect to socket /temp/dbus/....
It is possible to recover a session for user in deleting its profile and
recreating it (and copying its files except hidden files)

Expected results:
Gnome session should start after customization of the environment.

Additional info:
I join my xorg.conf file to show you my devices, which are correctly detected.
I also join the list of all my packages and the error message I get when I write
startx under prompt from user session.

Let me known if you need some more information.
Regards.
Comment 1 stephane ploix 2006-04-30 16:26:16 EDT
Error message:

xauth:  creating new authority file /home/stephane/.serverauth.2348
xauth:  creating new authority file /home/stephane/.Xauthority
xauth:  creating new authority file /home/stephane/.Xauthority


X Window System Version 7.0.0
Release Date: 21 December 2005
X Protocol Version 11, Revision 0, Release 7.0
Build Operating System:Linux 2.6.9-22.18.bz155725.ELsmp i686Red Hat, Inc.
Current Operating System: Linux serveur.ploix.com 2.6.15-1.2054_FC5 #1 Tue Mar
14 15:48:33 EST 2006 i686
Build Date: 06 March 2006
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sun Apr 30 19:55:56 2006
(==) Using config file: "/etc/X11/xorg.conf"
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:          Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
>                   Ignoring extra symbols
Errors from xkbcomp are not fatal to the X server
SESSION_MANAGER=local/serveur.ploix.com:/tmp/.ICE-unix/2369
Impossible d'ouvrir le fichier de bureau
/usr/share/applications/openoffice.org-1.9-writer.desktop pour le lanceur du
tableau de bord: Erreur lors de la lecture du fichier
« /usr/share/applications/openoffice.org-1.9-writer.desktop » : Fichier non trouvé
Impossible d'ouvrir le fichier de bureau
/usr/share/applications/openoffice.org-1.9-impress.desktop pour le lanceur du
tableau de bord: Erreur lors de la lecture du fichier
« /usr/share/applications/openoffice.org-1.9-impress.desktop » : Fichier non trouvé
Impossible d'ouvrir le fichier de bureau
/usr/share/applications/openoffice.org-1.9-calc.desktop pour le lanceur du
tableau de bord: Erreur lors de la lecture du fichier
« /usr/share/applications/openoffice.org-1.9-calc.desktop » : Fichier non trouvé

** (eggcups:2426): WARNING **: IPP request failed with status 1030

   *** If unresolved symbols were reported above, they might not
   *** be the reason for the server aborting.

Backtrace:
0: X(xf86SigHandler+0x87) [0x80b85e7]
1: [0x9d0420]
2: /usr/lib/xorg/modules/libfb.so(fbCopyAreammx+0x1e2) [0x412442]
3: /usr/lib/xorg/modules/libfb.so(fbCompositeCopyAreammx+0x66) [0x412566]
4: /usr/lib/xorg/modules/libfb.so(fbComposite+0x57b) [0x40316b]
5: /usr/lib/xorg/modules/libxaa.so(XAAComposite+0x261) [0xce6261]
6: X [0x8154306]
7: X(CompositePicture+0xf7) [0x8141f27]
8: X [0x8147c8c]
9: X [0x8144fc5]
10: X(Dispatch+0x19b) [0x80888eb]
11: X(main+0x487) [0x80701d7]
12: /lib/libc.so.6(__libc_start_main+0xdc) [0x1267e4]
13: X(FontFileCompleteXLFD+0xb1) [0x806f511]

Fatal server error:
Caught signal 11.  Server aborting

Avertissement du gestionnaire de fenêtres : Perte de la connexion avec le visuel
« :0.0 » ;
le serveur X a probablement été arrêté ou vous avez tué/détruit
le gestionnaire de fenêtres.
The application 'nm-applet' lost its connection to the display :0.0;
most likely the X server was shut down or you killed/destroyed
the application.
The application 'nautilus' lost its connection to the display :0.0;
most likely the X server was shut down or you killed/destroyed
the application.
The application 'bluez-pin' lost its connection to the display :0.0;
most likely the X server was shut down or you killed/destroyed
the application.
The application 'pam-panel-icon' lost its connection to the display :0.0;
most likely the X server was shut down or you killed/destroyed
the application.
The application 'eggcups' lost its connection to the display :0.0;
most likely the X server was shut down or you killed/destroyed
the application.
xinit:  connection to X server lost.

The application 'gnome-panel' lost its connection to the display :0.0;
most likely the X server was shut down or you killed/destroyed
the application.

** (gnome-panel:2418): WARNING **: FIXME: wait for completion unimplemented
Comment 2 Ray Strode [halfline] 2008-03-18 14:33:34 EDT
Hi,

We no longer support Fedora Core 5 and I am currently trying to get my open bug
count down to a more manageable state.  I'm going to close this bug as WONTFIX.
 If this issue is still a concern for you, would you mind trying to reproduce on
a supported version of Fedora and reopening?

(this is a mass message)

Note You need to log in before you can comment on or make changes to this bug.