Bug 190322 - Rebuild from SRPM fails to check for dependency libXxf86dga-devel
Summary: Rebuild from SRPM fails to check for dependency libXxf86dga-devel
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kdemultimedia   
(Show other bugs)
Version: 5
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-05-01 05:38 UTC by Joseph D. Wagner
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-04 12:17:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log of failed build. (1.08 MB, text/plain)
2006-05-04 11:00 UTC, Joseph D. Wagner
no flags Details
List of installed RPMS. (19.07 KB, text/plain)
2006-05-04 11:01 UTC, Joseph D. Wagner
no flags Details
diff of changes I made to the SPEC file. (815 bytes, text/plain)
2006-05-04 11:05 UTC, Joseph D. Wagner
no flags Details
Proposed patch to kdemultimedia.spec. (683 bytes, patch)
2006-05-04 11:06 UTC, Joseph D. Wagner
no flags Details | Diff

Description Joseph D. Wagner 2006-05-01 05:38:49 UTC
Description of problem:
kdemultimedia-3.5.2-0.1.fc5.src.rpm fails to check for dependency 
libXxf86dga-devel, which is needed during build time.

Version-Release number of selected component (if applicable):
kdemultimedia-3.5.2-0.1.fc5.src.rpm

How reproducible:
Always

Steps to Reproduce:
simply type 'rpmbuild --rebuild kdemultimedia-3.5.2-0.1.fc5.src.rpm' on any 
system that does not have libXxf86dga-devel installed.
  
Actual results:
The build process exits on error.

Expected results:
The package should build properly.

Comment 1 Ngo Than 2006-05-02 14:08:51 UTC
kdemultimedia built fine here without installed libXxf86dga-devel.
The output of "rpm -q --requires kdemultimedia" does not show the requirement on
libXxf86dga! Could you please attach the log file of your rebuild? Thanks

Comment 2 Joseph D. Wagner 2006-05-04 10:58:40 UTC
I'm sorry.  I left out some information, but this should clear up the nature 
of the bug.

I did make a few, slight modifications to the SPEC file, so it isn't the exact 
same out-of-the-box SPEC file that you are distributing.  I realize you may 
view this as unsupported; however, the primary change is the line "%define 
build_mpeglib" from "0" to "1", and since the SPEC file has multiple areas of 
conditional code based upon this field, it implies that the build should still 
work if this field changes.

An exact list of the changes is in an attached diff file.  I also realize that 
with "%define build_mpeglib 1" the sources distributed with the SRPM need to 
be replaced with the original, pristine, unpatched sources directly from KDE.  
I did that.

I attached a list of installed packages at the time of the failed build.  You 
may find noteworthy that libXxf86dga is installed, but libXxf86dga-devel is 
not installed.

The attached build log confirms that under these conditions libXxf86dga-devel 
is indeed required for building.

Due to the fact that this bug depends upon modifications to the original, 
distributed SPEC file, I took the extra step of creating a proposed patch. The 
patch tested OK on my computer.

I hope this helps, and I do hope this patch is integrated into your SPEC file 
and not just brushed aside as unsupported.

Comment 3 Joseph D. Wagner 2006-05-04 11:00:27 UTC
Created attachment 128596 [details]
Log of failed build.

Comment 4 Joseph D. Wagner 2006-05-04 11:01:14 UTC
Created attachment 128597 [details]
List of installed RPMS.

Comment 5 Joseph D. Wagner 2006-05-04 11:05:20 UTC
Created attachment 128598 [details]
diff of changes I made to the SPEC file.

In addition to the changes specified in this diff file, I also substituted the
sources distributed with the SRPM with the original, pristine, unpatched
sources directly from KDE.

Comment 6 Joseph D. Wagner 2006-05-04 11:06:05 UTC
Created attachment 128599 [details]
Proposed patch to kdemultimedia.spec.

Comment 7 Ngo Than 2006-05-04 12:17:53 UTC
i have overlooked the mpeg stuff here. Of course, this build requirement will be
included in next kde rebuild. Thanks again for your report.


Note You need to log in before you can comment on or make changes to this bug.