Bug 1903222 - efl missing version is causing problems on attempts to update libavif
Summary: efl missing version is causing problems on attempts to update libavif
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: efl
Version: 33
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1905316 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-12-01 16:39 UTC by Michal Jaegermann
Modified: 2020-12-13 02:09 UTC (History)
5 users (show)

Fixed In Version: efl-1.25.1-4.fc33
Doc Type: ---
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-12-13 02:09:44 UTC
Type: Bug


Attachments (Terms of Use)

Description Michal Jaegermann 2020-12-01 16:39:42 UTC
Description of problem:

In Changelog for the efl package one can find:

* Fri Oct 23 2020 Nils Philippsen <nils@tiptoe.de> - 1.25.1-2
- rebuild for new libavif

Only, according to koji, these rebuilds failed; both for F33 and F34.  No specific reasons recorded.  And the net effect is currently that new libavif went to updates anyway and one gets:

 Problem: package efl-1.25.1-1.fc33.x86_64 requires libavif.so.6()(64bit), but none of the providers can be installed
  - cannot install both libavif-0.8.2-1.fc33.x86_64 and libavif-0.8.1-1.fc33.x86_64
  - cannot install both libavif-0.8.1-1.fc33.x86_64 and libavif-0.8.2-1.fc33.x86_64
  - cannot install the best update candidate for package libavif-0.8.1-1.fc33.x86_64
  - cannot install the best update candidate for package efl-1.25.1-1.fc33.x86_64

Version-Release number of selected component (if applicable):
efl-1.25.1-2.fc33.x86_64 (missing)

Comment 1 Fedora Update System 2020-12-04 19:20:39 UTC
FEDORA-2020-cd01c4d735 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-cd01c4d735

Comment 2 Michal Jaegermann 2020-12-05 00:41:40 UTC
(In reply to Fedora Update System from comment #1)
> FEDORA-2020-cd01c4d735 has been submitted as an update to Fedora 33.
> https://bodhi.fedoraproject.org/updates/FEDORA-2020-cd01c4d735

As expected this works; i.e. it is possible to upgrade to efl-1.25.1-4.fc33 and to efl-devel-1.25.1-4.fc33 and this allows updates to libavif too.  Related to bug 1891658 where a similar solution is applied.

Comment 3 Fedora Update System 2020-12-05 02:00:00 UTC
FEDORA-2020-cd01c4d735 has been pushed to the Fedora 33 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-cd01c4d735`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-cd01c4d735

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 4 Tom "spot" Callaway 2020-12-08 03:26:50 UTC
*** Bug 1905316 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Update System 2020-12-13 02:09:44 UTC
FEDORA-2020-cd01c4d735 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.