Bug 190331 - XmList widget size problem
Summary: XmList widget size problem
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: openmotif
Version: 5
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-05-01 10:29 UTC by Georg Wild
Modified: 2007-11-30 22:11 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2007-08-29 12:52:31 UTC


Attachments (Terms of Use)

Description Georg Wild 2006-05-01 10:29:49 UTC
Description of problem:
When using openmotif for xmgrace as provided by fc5 xmgrace set menu collapses
and makes xmgrace nearly unusable. The problem is described in
http://plasma-gate.weizmann.ac.il/Grace/phpbb/viewtopic.php?t=569 ,
the fix is available at http://bugs.motifzone.net/show_bug.cgi?id=1331 .

Comment 1 Matthew Truch 2006-05-05 03:24:15 UTC
I would like to vote for the fix to be pulled into Fedora's openmotif as well,
as this bug also affects gpsd (see Bug 189222).  

Thanks.

Comment 2 vossman 2006-06-21 20:15:53 UTC
Ugh, this bug is sooooo annoying. I pasted the pathc below (3 characters!!!).
For myself, I gave up and I decided to patch it and build form source.

--- openmotif-2.3.0/lib/Xm/List.c.vizcount 2006-03-24 16:45:01.000000000 -0600
+++ openmotif-2.3.0/lib/Xm/List.c 2006-03-24 16:45:35.000000000 -0600
@@ -2672,7 +2672,7 @@
XmRenderTableGetDefaultFontExtents(lw->list.font, &height, NULL, NULL);

lw->list.MaxItemHeight = (Dimension)height;
- if (lw->list.MaxItemHeight)
+ if (lw->list.MaxItemHeight == 0)
lw->list.MaxItemHeight = 1;
#else
if (XmeRenderTableGetDefaultFont(lw->list.font, &fs))

Comment 3 Fedora Update System 2006-06-22 19:30:00 UTC
openmotif-2.3.0-0.1.9.3 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.