Bug 190333 - jbuilderx opentool failure with 2.6.16 kernels
jbuilderx opentool failure with 2.6.16 kernels
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-01 08:01 EDT by Jozsef Banszki
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-14 07:28:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jozsef Banszki 2006-05-01 08:01:49 EDT
Description of problem:
JBuilderX doesn't start with >=2.6.16-1 kernels. With original 2.6.15 fc5 kernel
works fine.

Version-Release number of selected component (if applicable):
kernel >=2.6.16-1

How reproducible:
Please start JBuilderX.

Steps to Reproduce:
1. update the kernel at least 2.6.16-1.xxxx.FC5
2. try start jbuilderx
3.
  
Actual results:
doesn't start jbuilderx, write some errors

Expected results:
[jnc@bjnblinux ~]$ /opt/JBuilderX/bin/jbuilder
Use -verbose for details on OpenTool failures
*** OpenTool com.borland.jbuilder.webservices.personality.WebServicesPersonality
failed to initialize
*** OpenTool com.borland.jbuilder.personality.J2MEPersonality failed to initialize
*** OpenTool com.borland.jbuilder.personality.JBuilderPersonalities failed to
initialize
*** OpenTool com.borland.jbuilder.JBuilderCore failed to initialize
[jnc@bjnblinux ~]$ uname -r
2.6.16-1.2096_FC5

Additional info:
with -verbose:

[jnc@bjnblinux ~]$ /opt/JBuilderX/bin/jbuilder -verbose
Scanning manifest from /opt/JBuilderX/jdk1.4/lib/tools.jar
Scanning manifest from /opt/JBuilderX/lib/xmlParserAPIs.jar
Scanning manifest from /opt/JBuilderX/lib/cx.jar
Scanning manifest from /opt/JBuilderX/lib/BorlandLookAndFeel.jar
Scanning manifest from /opt/JBuilderX/lib/beandt.jar
Scanning manifest from /opt/JBuilderX/lib/xmldbms.jar
Scanning manifest from /opt/JBuilderX/lib/sanct2.jar
Scanning manifest from /opt/JBuilderX/lib/jdbcx.jar
Scanning manifest from /opt/JBuilderX/lib/internetbeans.jar
Scanning manifest from /opt/JBuilderX/lib/webservices.jar
Blocking com.borland.jbuilder.webservices.toolkits.weblogic.node.WLDUFileNode
initialization
Blocking
com.borland.jbuilder.webservices.toolkits.weblogic.node.wldu.WlduNodePropertyGroup
initialization
Blocking
com.borland.jbuilder.webservices.toolkits.weblogic.node.webservicesnode.WebServicesNodePropertyGroup
initialization
Blocking
com.borland.jbuilder.webservices.toolkits.weblogic.node.ear.ContextAction
initialization
Blocking com.borland.jbuilder.webservices.node.wsdl.ContextAction
initializationBlocking com.borland.jbuilder.webservices.node.java.ContextAction
initializationBlocking com.borland.jbuilder.webservices.node.DesignerWebAppNode
initializationBlocking com.borland.jbuilder.webservices.node.DesignerClientNode
initializationBlocking
com.borland.jbuilder.webservices.toolkits.weblogic.build.WeblogicServicegenBuilder
initialization
Blocking com.borland.jbuilder.webservices.enterprise.EjbWebServicePropertyGroup
initialization
Blocking
com.borland.jbuilder.webservices.toolkits.soapv2.wizard.configuration.WebServicesConfigurationWizard
initialization
Blocking com.borland.jbuilder.webservices.wizard.wsdl2java.Wsdl2JavaWizard
initialization
Blocking com.borland.jbuilder.webservices.wizard.java2wsdl.Java2WsdlWizard
initialization
Blocking com.borland.jbuilder.webservices.wizard.async2wsdl.Async2WsdlWizard
initialization
Scanning manifest from /opt/JBuilderX/lib/DoctypeChanger.jar
Scanning manifest from /opt/JBuilderX/lib/linuxDesktopConfigurator.jar
Scanning manifest from /opt/JBuilderX/lib/xmlbeans.jar
Scanning manifest from /opt/JBuilderX/lib/unittest.jar
Scanning manifest from /opt/JBuilderX/lib/jakarta-regexp-1.1.jar
Scanning manifest from /opt/JBuilderX/lib/xercesImpl.jar
Scanning manifest from /opt/JBuilderX/lib/mobiledev.jar
Scanning manifest from /opt/JBuilderX/lib/starteam-gui.jar
Scanning manifest from /opt/JBuilderX/lib/iastools.jar
Scanning manifest from /opt/JBuilderX/lib/jdsserver.jar
Scanning manifest from /opt/JBuilderX/lib/commons-logging.jar
Scanning manifest from /opt/JBuilderX/lib/webserverglue.jar
Scanning manifest from /opt/JBuilderX/lib/ant.jar
Scanning manifest from /opt/JBuilderX/lib/jbcl.jar
Scanning manifest from /opt/JBuilderX/lib/ias_common60.jar
Scanning manifest from /opt/JBuilderX/lib/streplicate.jar
Scanning manifest from /opt/JBuilderX/lib/bsf.jar
Scanning manifest from /opt/JBuilderX/lib/sqltools.jar
Scanning manifest from /opt/JBuilderX/lib/dt.jar
Scanning manifest from /opt/JBuilderX/lib/starteam-extensions.jar
Scanning manifest from /opt/JBuilderX/lib/jbuilder.jar
Blocking com.borland.jbuilder.cmt2.designer.DesignerPropertyGroup
initializationBlocking com.borland.jbuilder.cmt2.designer.DesignerViewerFactory
initializationBlocking com.borland.jbuilder.cmt2.designer.tree.ComponentView
initialization
Blocking com.borland.jbuilder.wizard.vcafeproject.ImportProjectWizard initialization
Blocking com.borland.jbuilder.cmt2.designer.DesignerManager initialization
Blocking com.borland.jbuilder.enterprise.ejb.DeployPropertyGroup initialization
Scanning manifest from /opt/JBuilderX/lib/activation.jar
Scanning manifest from /opt/JBuilderX/lib/castor-xml.jar
Scanning manifest from /opt/JBuilderX/lib/dbswing.jar
Scanning manifest from /opt/JBuilderX/lib/mail.jar
Scanning manifest from /opt/JBuilderX/lib/soap.jar
Scanning manifest from /opt/JBuilderX/lib/ias_common65.jar
Scanning manifest from /opt/JBuilderX/lib/jaxrpc.jar
Scanning manifest from /opt/JBuilderX/lib/jds.jar
Scanning manifest from /opt/JBuilderX/lib/dbswingdt.jar
Scanning manifest from /opt/JBuilderX/lib/jdom.jar
Scanning manifest from /opt/JBuilderX/lib/uddi4j.jar
Scanning manifest from /opt/JBuilderX/lib/commons-discovery.jar
Scanning manifest from /opt/JBuilderX/lib/sbtoolbar.jar
Scanning manifest from /opt/JBuilderX/lib/admintool.jar
Scanning manifest from /opt/JBuilderX/lib/jdsremote.jar
Scanning manifest from /opt/JBuilderX/lib/log4j-1.2.8.jar
Scanning manifest from /opt/JBuilderX/lib/dtdparser.jar
Scanning manifest from /opt/JBuilderX/lib/axis-ant.jar
Scanning manifest from /opt/JBuilderX/lib/starteam54.jar
Scanning manifest from /opt/JBuilderX/lib/primetime.jar
Scanning manifest from /opt/JBuilderX/lib/axis.jar
Scanning manifest from /opt/JBuilderX/lib/optional.jar
Scanning manifest from /opt/JBuilderX/lib/resolver.jar
Scanning manifest from /opt/JBuilderX/lib/saaj.jar
Scanning manifest from /opt/JBuilderX/lib/wsdl4j.jar
Scanning manifest from /opt/JBuilderX/lib/help.jar
Scanning manifest from /opt/JBuilderX/lib/dx.jar
Scanning manifest from /opt/JBuilderX/lib/dbtools.jar
Scanning manifest from /opt/JBuilderX/lib/bes/xmlrt_jb.jar
Scanning manifest from /opt/JBuilderX/lib/bes/guicore_jb.jar
Scanning manifest from /opt/JBuilderX/lib/bes/vbjorb.jar
Scanning manifest from /opt/JBuilderX/lib/bes/scu_client.jar
Scanning manifest from /opt/JBuilderX/lib/bes/broker.jar
Scanning manifest from /opt/JBuilderX/lib/bes/scu.jar
Scanning manifest from /opt/JBuilderX/lib/bes/vbejb.jar
Scanning manifest from /opt/JBuilderX/lib/bes/agentclient.jar
Scanning manifest from /opt/JBuilderX/lib/servers/iplanet-jbsp.jar
Scanning manifest from /opt/JBuilderX/lib/servers/weblogic-jbsp.jar
Scanning manifest from /opt/JBuilderX/lib/servers/websphere-jbsp.jar
Scanning manifest from /opt/JBuilderX/lib/servers/jboss-jbsp.jar
Scanning manifest from /opt/JBuilderX/lib/servers/bes-jbsp.jar
Scanning manifest from /opt/JBuilderX/lib/servers/tomcat-jbsp.jar
Scanning manifest from /opt/JBuilderX/lib/ext/oijb10plugin.jar
Blocking com.borland.jbuilder.optimize.IntroOptimizeitProfiler initialization
Blocking com.borland.jbuilder.optimize.IntroOptimizeitCoverageAnalyzer
initialization
Blocking com.borland.jbuilder.optimize.IntroOptimizeitThreadDebugger initialization
Scanning manifest from /opt/JBuilderX/lib/ext/QCClient.jar
Scanning manifest from
/opt/JBuilderX/thirdparty/jakarta-tomcat-4.0.6-LE-jdk14/common/lib/servlet.jar
Scanning manifest from /opt/JBuilderX/thirdparty/InterClient/interclient.jar
OpenTools discovered (607ms)
--- Initializing OpenTools-Core
*** OpenTool com.borland.jbuilder.webservices.personality.WebServicesPersonality
failed to initialize
java.lang.reflect.InvocationTargetException
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:324)
        at com.borland.primetime.PrimeTime.b(Unknown Source)
        at com.borland.primetime.PrimeTime.initializeOpenTools(Unknown Source)
        at com.borland.primetime.PrimeTime.initializeOpenTools(Unknown Source)
        at com.borland.primetime.PrimeTime.start(Unknown Source)
        at com.borland.jbuilder.JBuilder.main(Unknown Source)
Caused by: java.lang.NoClassDefFoundError
        at java.awt.Component.<clinit>(Component.java:506)
        at com.borland.primetime.util.Images.<clinit>(Unknown Source)
        at com.borland.jbuilder.ide.JBuilderIcons.<clinit>(Unknown Source)
        at com.borland.jbuilder.node.JBProject.<clinit>(Unknown Source)
        at java.lang.Class.forName0(Native Method)
        at java.lang.Class.forName(Class.java:141)
        at
com.borland.jbuilder.webservices.personality.WebServicesPersonality.class$(Unknown
Source)
        at
com.borland.jbuilder.webservices.personality.WebServicesPersonality.initOpenTool(Unknown
Source)
        ... 9 more
OpenTool com.borland.jbuilder.obfuscator.micro.ObfuscatorPathSetFactory (3+1ms)
*** OpenTool com.borland.jbuilder.personality.J2MEPersonality failed to initialize
java.lang.reflect.InvocationTargetException
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:324)
        at com.borland.primetime.PrimeTime.b(Unknown Source)
        at com.borland.primetime.PrimeTime.initializeOpenTools(Unknown Source)
        at com.borland.primetime.PrimeTime.initializeOpenTools(Unknown Source)
        at com.borland.primetime.PrimeTime.start(Unknown Source)
        at com.borland.jbuilder.JBuilder.main(Unknown Source)
Caused by: java.lang.NoClassDefFoundError
        at java.lang.Class.forName0(Native Method)
        at java.lang.Class.forName(Class.java:141)
        at com.borland.jbuilder.personality.J2MEPersonality.class$(Unknown Source)
        at com.borland.jbuilder.personality.J2MEPersonality.initOpenTool(Unknown
Source)
        ... 9 more
OpenTool com.borland.primetime.personality.PrimetimePersonality (0+0ms)
*** OpenTool com.borland.jbuilder.personality.JBuilderPersonalities failed to
initialize
java.lang.reflect.InvocationTargetException
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:324)
        at com.borland.primetime.PrimeTime.b(Unknown Source)
        at com.borland.primetime.PrimeTime.initializeOpenTools(Unknown Source)
        at com.borland.primetime.PrimeTime.initializeOpenTools(Unknown Source)
        at com.borland.primetime.PrimeTime.start(Unknown Source)
        at com.borland.jbuilder.JBuilder.main(Unknown Source)
Caused by: java.lang.NoClassDefFoundError
        at java.lang.Class.forName0(Native Method)
        at java.lang.Class.forName(Class.java:141)
        at com.borland.jbuilder.personality.JBuilderPersonalities.a(Unknown Source)
        at
com.borland.jbuilder.personality.JBuilderPersonalities.initOpenTool(Unknown Source)
        ... 9 more
OpenTool com.borland.primetime.personality.TeamdevPersonality (1+0ms)
OpenTool com.borland.jbuilder.build.BuildCommand (30+26ms)
*** OpenTool com.borland.jbuilder.JBuilderCore failed to initialize
java.lang.reflect.InvocationTargetException
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:324)
        at com.borland.primetime.PrimeTime.b(Unknown Source)
        at com.borland.primetime.PrimeTime.initializeOpenTools(Unknown Source)
        at com.borland.primetime.PrimeTime.initializeOpenTools(Unknown Source)
        at com.borland.primetime.PrimeTime.start(Unknown Source)
        at com.borland.jbuilder.JBuilder.main(Unknown Source)
Caused by: java.lang.NoClassDefFoundError
        at com.borland.jbuilder.info.JBuilderInfo.<clinit>(Unknown Source)
        at com.borland.jbuilder.JBuilderCore.initOpenTool(Unknown Source)
        ... 9 more
OpenTool com.borland.jbuilder.java.JavacValidator (1+5ms)
--- OpenTools-Core initialized (480ms total)
Comment 1 Jozsef Banszki 2006-05-14 07:32:49 EDT
I found the solution on the
http://stanton-finley.net/fedora_core_5_installation_notes.html web site, at the
java installation notes:

"If you have not already done so go to "System" > "Administration" > "Security
Level and Firewall". Enter your root password and click "ok". On the "SELinux"
tab click on "Modify SELinux Policy", click on "Compatibility" to open it and
tick the check box next to "Allow the use of shared libraries with Text
Relocation". Click "ok". Reboot your machine to implement the new SELinux policy."

This resolve my problem.

Note You need to log in before you can comment on or make changes to this bug.