Bug 190373 - File update breaks mediawiki
File update breaks mediawiki
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: file (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Radek Vokal
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-01 15:41 EDT by Pat Gunn
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 4.17-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-10 05:06:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
*.ppt files entry in ./magic/magic.mime has been fixed (550.50 KB, patch)
2006-07-03 08:36 EDT, Adam Tkac
no flags Details | Diff
ppt magic entry has been fixed (625 bytes, patch)
2006-07-03 09:28 EDT, Adam Tkac
no flags Details | Diff

  None (edit)
Description Pat Gunn 2006-05-01 15:41:12 EDT
Description of problem:Upgrade of file utility breaks MediaWiki


Version-Release number of selected component (if applicable):4.17.2


How reproducible:100%


Steps to Reproduce:
1. Version of file that comes with FC5/amd64 (file-4.16-6.2), when run on
microsoft office documents, typically returns application/msword. file 4.17.2,
which was recently pushed out through the update channel, returns nothing, which
causes Mediawiki to break when it tries to verify the extension of uploaded
files with the mime type detected. Reverting to the old file package fixes things.
Comment 1 Pat Gunn 2006-05-01 15:44:09 EDT
I should note that you must configure mediawiki to allow office documents to be
directly bitten by this and mediawiki, but also that some other software that
depends on magic and file to detect mimetypes also is bitten by this change.
This kind of change is probably better made between major fedora releases than
within them.
Comment 2 Radek Vokal 2006-05-02 09:16:04 EDT
rvokal@garfield ~$ file -i ipsec.doc
ipsec.doc: application/msword
rvokal@garfield ~$ file ipsec.doc
ipsec.doc: Microsoft Office Document
rvokal@garfield ~$ rpm -q file
file-4.17-3

Do you have some specific file which is not correctly recognized? Can you attach it?
Comment 3 Pat Gunn 2006-05-02 10:33:43 EDT
It actually seems to be ok with .doc files, but .ppt files tend to break. I
can't provide the actual powerpoints that caused it to fail (due to HIPPA
requirements), but I can point you at some other unrelated ppt files that also
fail. Download any of the .ppt files from:
http://www.cmu.edu/bio/education/courses/03310/LectureNotes/

tremor:~$ file -bi ./notes/spring-2006/comp_bio03510/lecturenotes/LecturesPart01.ppt

tremor:~$
Comment 4 Adam Tkac 2006-07-03 08:36:13 EDT
Created attachment 131881 [details]
*.ppt files entry in ./magic/magic.mime has been fixed

line 841 has been replaced by line 852
Comment 5 Adam Tkac 2006-07-03 09:28:59 EDT
Created attachment 131882 [details]
ppt magic entry has been fixed

apply patch to file/magic/magic.mime
Comment 6 Radek Vokal 2006-07-10 05:06:43 EDT
Patch applied on rawhide. Thanks
Comment 7 Dmitry Butskoy 2006-10-24 10:06:31 EDT
The same issue, but with .xls file (the file has the same magic).
The patch fixes it too.

Maybe ship rawhide's version as update for FC5?

Note You need to log in before you can comment on or make changes to this bug.