Bug 190401 - NULL pointer dereference in nfsd:nfsd_svc when starting rgmanager/nfs services
NULL pointer dereference in nfsd:nfsd_svc when starting rgmanager/nfs services
Status: CLOSED DUPLICATE of bug 175629
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-01 18:24 EDT by Corey Marthaler
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-09 06:06:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Marthaler 2006-05-01 18:24:59 EDT
Description of problem:
This is similar to bz 175629 (if not a dup). This happened on
taft-01.lab.msp.redhat.com when starting rgmanager/nfs services.

Resource info:
<rm>
                        <failoverdomains>
                                <failoverdomain name="TAFT_CLUSTER_domain"
ordered="0" restricted="0">
                                        <failoverdomainnode name="taft-01"
priority="1"/>
                                        <failoverdomainnode name="taft-02"
priority="1"/>
                                        <failoverdomainnode name="taft-03"
priority="1"/>
                                        <failoverdomainnode name="taft-04"
priority="1"/>
                                </failoverdomain>
                        </failoverdomains>
                        <resources>
                                <ip address="10.15.89.191" monitor_link="1"/>
                                <ip address="10.15.89.192" monitor_link="1"/>
                                <clusterfs
device="/dev/TAFT_CLUSTER/TAFT_CLUSTER0" force_unmount="0" fsid="8203"
fstype="gfs" mountpoint="/mnt/taft0" name="TAFT_CLUSTER0" options=""/>
                                <clusterfs
device="/dev/TAFT_CLUSTER/TAFT_CLUSTER1" force_unmount="0" fsid="2078"
fstype="gfs" mountpoint="/mnt/taft1" name="TAFT_CLUSTER1" options=""/>
                                <fs device="/dev/TAFT_CLUSTER/TAFT_CLUSTER2"
force_fsck="0" force_unmount="0" fsid="3839" fstype="ext3" mountpoint="/mnt/one"
name="TAFT_CLUSTER2" options=""/>
                                <clusterfs
device="/dev/TAFT_CLUSTER/TAFT_CLUSTER3" force_unmount="0" fsid="9364"
fstype="gfs" mountpoint="/mnt/taft2" name="TAFT_CLUSTER3" options=""/>
                                <clusterfs
device="/dev/TAFT_CLUSTER/TAFT_CLUSTER4" force_unmount="0" fsid="6183"
fstype="gfs" mountpoint="/mnt/taft3" name="TAFT_CLUSTER4" options=""/>
                                <fs device="/dev/TAFT_CLUSTER/TAFT_CLUSTER5"
force_fsck="0" force_unmount="0" fsid="3516" fstype="ext3" mountpoint="/mnt/two"
name="TAFT_CLUSTER5" options=""/>
                                <nfsexport name="TAFT_CLUSTER nfs exports"/>
                                <nfsclient name="*" options="rw" target="*"/>
                                <nfsclient name="flea-01" options="rw"
target="flea-01"/>
                        </resources>
                        <service autostart="1" domain="TAFT_CLUSTER_domain"
name="nfs1">
                                <clusterfs ref="TAFT_CLUSTER0">
                                        <nfsexport ref="TAFT_CLUSTER nfs exports">
                                                <nfsclient ref="*"/>
                                        </nfsexport>
                                </clusterfs>
                                <clusterfs ref="TAFT_CLUSTER1">
                                        <nfsexport ref="TAFT_CLUSTER nfs exports">
                                                <nfsclient ref="*"/>
                                        </nfsexport>
                                </clusterfs>
                                <fs ref="TAFT_CLUSTER2">
                                        <nfsexport ref="TAFT_CLUSTER nfs exports">
                                                <nfsclient ref="*"/>
                                        </nfsexport>
                                </fs>
                                <ip ref="10.15.89.191"/>
                        </service>
                        <service autostart="1" domain="TAFT_CLUSTER_domain"
name="nfs2">
                                <clusterfs ref="TAFT_CLUSTER3">
                                        <nfsexport ref="TAFT_CLUSTER nfs exports">
                                                <nfsclient ref="flea-01"/>
                                        </nfsexport>
                                </clusterfs>
                                <clusterfs ref="TAFT_CLUSTER4">
                                        <nfsexport ref="TAFT_CLUSTER nfs exports">
                                                <nfsclient ref="flea-01"/>
                                        </nfsexport>
                                </clusterfs>
                                <fs ref="TAFT_CLUSTER5">
                                        <nfsexport ref="TAFT_CLUSTER nfs exports">
                                                <nfsclient ref="flea-01"/>
                                        </nfsexport>
                                </fs>
                                <ip ref="10.15.89.192"/>
                        </service>
                </rm>

[root@taft-02 ~]# clustat
Member Status: Quorate

  Member Name                              Status
  ------ ----                              ------
  taft-01                                  Offline
  taft-02                                  Online, Local, rgmanager
  taft-03                                  Online, rgmanager
  taft-04                                  Online, rgmanager

  Service Name         Owner (Last)                   State
  ------- ----         ----- ------                   -----
  nfs1                 taft-04                        started
  nfs2                 taft-04                        started



May  1 11:09:16 taft-01 clurgmgrd[13220]: <notice> Resource Group Manager Start
May  1 11:09:16 taft-01 clurgmgrd[13220]: <info> Loading Service Data
May  1 11:09:16 taft-01 rgmanager: clurgmgrd startup succeeded
May  1 11:09:16 taft-01 clurgmgrd[13220]: <info> Initializing Services
Unable to handle kernel NULL pointer dereference at 0000000000000038 RIP:
<ffffffffa02de1d8>{:nfsd:nfsd_svc+454}
PML4 170495067 PGD 0
Oops: 0000 [1] SMP
CPU 3
Modules linked in: nfsd exportfs lockd nfs_acl lock_dlm(U) gnbd(U) lock_nolock(d
Pid: 13609, comm: rpc.nfsd Not tainted 2.6.9-34.ELsmp
RIP: 0010:[<ffffffffa02de1d8>] <ffffffffa02de1d8>{:nfsd:nfsd_svc+454}
RSP: 0018:0000010173743e68  EFLAGS: 00010246
RAX: 0000000000000000 RBX: 0000000000000000 RCX: 0000000000000000
RDX: 0000000000016090 RSI: ffffffff804d9098 RDI: ffffffffa0312300
RBP: 0000000000000008 R08: 0000000000010800 R09: 0000000000008400
R10: 0000000000000000 R11: ffffffff8015bbfe R12: 0000000000000000
R13: 0000000000000002 R14: 0000007fbfffb480 R15: 0000000000002000
FS:  0000002a958a0b00(0000) GS:ffffffff804d7c80(0000) knlGS:0000000000000000
CS:  0010 DS: 0000 ES: 0000 CR0: 000000008005003b
CR2: 0000000000000038 CR3: 0000000037e24000 CR4: 00000000000006e0
Process rpc.nfsd (pid: 13609, threadinfo 0000010173742000, task 000001016512003)
Stack: 0000010153e27008 0000010173743e98 0000000000000008 ffffffffa02ded09
       0000010173743e99 0000010153e27009 0000007fbfff0038 0000007fbfffb480
       0000000000002000 ffffffff8015c223
Call Trace:<ffffffffa02ded09>{:nfsd:write_threads+131} <ffffffff8015c223>{get_z
       <ffffffff80195f39>{simple_transaction_get+152} <ffffffffa02de8ce>{:nfsd:
       <ffffffff80177c60>{vfs_write+207} <ffffffff80177d48>{sys_write+69}
       <ffffffff801101c6>{system_call+126}

Code: 2b 68 38 89 e8 8d 68 01 85 ed 7e 75 48 c7 c7 80 1d 31 a0 ff
RIP <ffffffffa02de1d8>{:nfsd:nfsd_svc+454} RSP <0000010173743e68>
CR2: 0000000000000038
 <0>Kernel panic - not syncing: Oops


Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux AS release 4 (Nahant Update 3)
Kernel 2.6.9-34.ELsmp on an x86_64
rgmanager-1.9.46-0

How reproducible:
once so far
Comment 1 Steve Dickson 2006-05-09 06:06:27 EDT

*** This bug has been marked as a duplicate of 175629 ***

Note You need to log in before you can comment on or make changes to this bug.