This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 190410 - FC5 installtion errors out on Apple G4 PPC system
FC5 installtion errors out on Apple G4 PPC system
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
: 190411 190412 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-01 22:28 EDT by Paul Stevens
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-17 16:06:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Paul Stevens 2006-05-01 22:28:43 EDT
Description of problem: When attempting to install FC5 on a Mac G4 867 MHz/2Mb 
cache  w/ 128 Mb RAM & 100 MB IDE drive.  The fisrt time through the 
installation I selected "Automatic Partitioning" and was able to respond to 
all questions leading up to the actual installation of files before the 
installation displayed an error trace.  On subsequent installation attempts 
the installation dumps right after selecting either manual or automatic 
partitioning.  The trace back follows:

File "/usr/lib/anaconda/gui.py", line 873, in nextClicked
self.dispatch.gotoNext()
File "/usr/lib/anaconda/dispatch.py", line 174, in gotoNext
self.moveStep()
File "/usr/lib/anaconda/dispatch.py", line 242 in moveStep
rc=apply(func, self.binArgs(args))
File "/usr/lib/anaconda/partitioning.py", line 54, in 
partitionObjectsInitialize
partitions.set FromDisk(diskset)
File "/usr/lib/anaconda/partitions.py", line 108, in getFromDisk
ptype=partedUtils.get_partitions_file_syste_type(part)
File "/usr/lib/anaconda/partedUtils.py", line 140, in 
get_partition_file_system_type
elif (part.get_flag(parted.PARTITION_BOOT)==1 and
AttributeError: 'NameType" Object has no attribute 'name'

I read in a Linux forum that this may be related to the Apple boot record 
being removed by the auto-partitioning routine and that a fix could be to use 
the Ubuntu Breezy Badger installation disk to re-write the boot record.  I 
obtained the UBB installation disk and am able to install UBB and boot the 
system.  I am still not able to install FC5 on the system.  Below is the 
output from "parted" from the FC5 installation routine:

Disk label type: mac

Minor    Start    End      Filesystem       Name        Flags
1        0.000   0.031                      Apple 
2        0.031   0.985                      Untitled    Boot
3        0.985  93553.575   EXT3            Untitled
4    93553.575  95396.273   Linux-Swap      Swap        swap`


Version-Release number of selected component (if applicable):


How reproducible: Each installation attempt


Steps to Reproduce:
1. Boot the system from the FC5 boot disk
2. Follow the installtion prompts until the partitioning method is presented
3. Select either manual or automatic partitioning
  
Actual results:  As indicated by the trace back above


Expected results:


Additional info:  This is not a dual boot installation attempt.  FC5 is 
intended to be the only OS on the system.
Comment 1 Jeremy Katz 2006-05-01 22:32:12 EDT
*** Bug 190411 has been marked as a duplicate of this bug. ***
Comment 2 Jeremy Katz 2006-05-01 22:50:49 EDT
*** Bug 190412 has been marked as a duplicate of this bug. ***
Comment 3 Paul Nasrat 2006-05-02 11:24:11 EDT
Please attach the full traceback output - you should be able to save to remote
host via scp.
Comment 4 Paul Stevens 2006-05-04 18:07:50 EDT
I was successful getting FC5 installed on this machine.  I first did a 
complete install of Ubuntu Breezy Badger (had always inturrupted install just 
after format of file systems) to make sure the system would boot, etc.  The I 
installed FC5 over top of the Ubuntu install making sure to use the disk druid 
method of partitioning and only formatting the Apple Boot, swap and / file 
systems.  Then the FC5 install went right through.  The first time I attempted 
FC5 install I selected auotmatice partitioning which (I have read) can have 
ill effects on /dev/hda1 partition.

So what to do with this bug report? I'm not married to the install yet so if 
you want me to try to reporduce the problem I'd be happy to.  I pretty sure 
that if I select auto partition again I'd be right in the same boat.  Let me 
know what you want me to do.

Comment 5 Paul Nasrat 2006-07-17 16:06:32 EDT
I'm going to close this out - if you have the same issue with fc6t2 or later
please file a bug containing the full anacdump.log not just the head of it.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.