Bug 19044 - "No Drives Found" during network install
"No Drives Found" during network install
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
6.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-13 09:08 EDT by Tim Clarke
Modified: 2007-04-18 12:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-23 14:47:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kickstart file - ok with bootnet.img (820 bytes, text/plain)
2001-02-15 15:12 EST, Tim Clarke
no flags Details
conf.modules created by RedHat 6.2 CD bootnet.img (84 bytes, text/plain)
2001-04-05 09:18 EDT, Tim Clarke
no flags Details

  None (edit)
Description Tim Clarke 2000-10-13 09:08:53 EDT
I get the message "No Drives Found" when trying to kickstart a Dell 2450
Poweredge using bootnet.img. The machine I am attempting to install to
currently had RedHat 6.2 loaded and running successfully (as does the
kickstart server). The kernel version in use is 2.2.14-6.1.smp. The full
error message reads:-

No Drives Found

An error has occurred - no valid devices were found on which to create new
filesystems. Please check your hardware for the cause of the problem.

The traceback reads:-

Exception occurred
Traceback (innermost, last):
File "/usr/bin/anaconda", line 343, in ? intf.run(todo, test=test)
File "/usr/lib/anaconda/text.py", line 1165 in run rc = apply(step[1](),
step[2])
File "/usr/lib/anaconda/text.py", line 210, in __call__
todo.intf.messageWindow)
File "/usr/lib/anaconda/fstab.py", line 670, in __init__
readOnly,waitWindow,messageWindow)
File "/usr/lib/anaconda/fstab.py", line 621 in __init__
self.ddruid=self.creatDruid()
File "/usr/lib/anaconda/fstab.py", line 597, in createDruid self.readOnly,
ignoreBadDriver)
TypeError: list of strings

I can supply much more info if you need it (Alt F3/Alt F4 logs), dmesg
outputs, /var/log/boot.log /var/log/messages, dhcpd.conf, kickstart files
etc.

I have 32 of these machines plus 32 Netfinity servers so network
installations would be extremely desirable.


Regards....Tim
Comment 1 Tim Clarke 2000-10-17 05:03:59 EDT
I just tried to install via kickstart/NFS on a brand new Netfinity 4500R and got
the same error "No Drives Found".

Regards....Tim
Comment 2 Michael Fulbright 2000-10-18 18:10:05 EDT
What kind of IDE/SCSI controllers/drives do you have?
Comment 3 Tim Clarke 2000-10-18 19:44:40 EDT
I hope the following extract from /var/log/dmesg on a running Dell machine will
help you:-


PCI_IDE: unknown IDE controller on PCI bus 00 device 79, VID=1166, DID=0211
PCI_IDE: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0x08b0-0x08b7, BIOS settings: hda:DMA, hdb:pio
    ide1: BM-DMA at 0x08b8-0x08bf, BIOS settings: hdc:pio, hdd:pio
hda: TOSHIBA CD-ROM XM-7002B, ATAPI CDROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
hda: ATAPI 24X CD-ROM drive, 128kB Cache
Uniform CDROM driver Revision: 2.56
Floppy drive(s): fd0 is 1.44M
FDC 0 is a National Semiconductor PC87306
md driver 0.90.0 MAX_MD_DEVS=256, MAX_REAL=12
raid5: measuring checksumming speed
raid5: MMX detected, trying high-speed MMX checksum routines
   pII_mmx   :  1485.138 MB/sec
   p5_mmx    :  1550.670 MB/sec
   8regs     :  1138.428 MB/sec
   32regs    :   669.036 MB/sec
using fastest function: p5_mmx (1550.670 MB/sec)
scsi : 0 hosts.
scsi : detected total.
md.c: sizeof(mdp_super_t) = 4096
Partition check:
RAMDISK: Compressed image found at block 0
autodetecting RAID arrays
autorun ...
... autorun DONE.
VFS: Mounted root (ext2 filesystem).
(scsi0) <Adaptec AIC-7899 Ultra 160/m SCSI host adapter> found at PCI 2/4/0
(scsi0) Wide Channel A, SCSI ID=7, 32/255 SCBs
(scsi0) Downloading sequencer code... 396 instructions downloaded
enable_irq() unbalanced from fc81bb26
(scsi1) <Adaptec AIC-7899 Ultra 160/m SCSI host adapter> found at PCI 2/4/1
(scsi1) Wide Channel B, SCSI ID=7, 32/255 SCBs
(scsi1) Downloading sequencer code... 396 instructions downloaded
enable_irq() unbalanced from fc81bb26
scsi0 : Adaptec AHA274x/284x/294x (EISA/VLB/PCI-Fast SCSI) 5.1.28/3.2.4
       <Adaptec AIC-7899 Ultra 160/m SCSI host adapter>
scsi1 : Adaptec AHA274x/284x/294x (EISA/VLB/PCI-Fast SCSI) 5.1.28/3.2.4
       <Adaptec AIC-7899 Ultra 160/m SCSI host adapter>
scsi : 2 hosts.
(scsi0:0:0:0) Synchronous at 160.0 Mbyte/sec, offset 63.
  Vendor: SEAGATE   Model: ST318404LC        Rev: 0002
  Type:   Direct-Access                      ANSI SCSI revision: 03
Detected scsi disk sda at scsi0, channel 0, id 0, lun 0
  Vendor: DELL      Model: 1x4 U2W SCSI BP   Rev: 1.15
  Type:   Processor                          ANSI SCSI revision: 02
SCSI device sda: hdwr sector= 512 bytes. Sectors= 35566478 [17366 MB] [17.4 GB]
 sda: sda1 sda2 sda3 sda4 < sda5 sda6 sda7 sda8 sda9 sda10 >

I can get the same information from a Netfinity later (once I have installed
Linux tomorrow).

Regards....Tim
Comment 4 Tim Clarke 2000-10-20 15:19:19 EDT
Here is the /var/log/dmesg file on the Netfinity after inatallation of the
non-smp 2.2.14-6.1.1 kernel:-

PCI_IDE: unknown IDE controller on PCI bus 00 device 79, VID=1166, DID=0211
PCI_IDE: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0x0840-0x0847, BIOS settings: hda:DMA, hdb:pio
    ide1: BM-DMA at 0x0848-0x084f, BIOS settings: hdc:pio, hdd:pio
hda: CRN-8241B, ATAPI CDROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
hda: ATAPI 24X CD-ROM drive, 128kB Cache
Uniform CDROM driver Revision: 2.56
Floppy drive(s): fd0 is 1.44M
FDC 0 is a National Semiconductor PC87306
md driver 0.90.0 MAX_MD_DEVS=256, MAX_REAL=12
raid5: measuring checksumming speed
raid5: MMX detected, trying high-speed MMX checksum routines
   pII_mmx   :  1626.108 MB/sec
   p5_mmx    :  1708.023 MB/sec
   8regs     :  1255.776 MB/sec
   32regs    :   703.707 MB/sec
using fastest function: p5_mmx (1708.023 MB/sec)
scsi : 0 hosts.
scsi : detected total.
md.c: sizeof(mdp_super_t) = 4096
Partition check:
RAMDISK: Compressed image found at block 0
autodetecting RAID arrays
autorun ...
... autorun DONE.
VFS: Mounted root (ext2 filesystem).
(scsi0) <Adaptec AIC-7899 Ultra 160/m SCSI host adapter> found at PCI 1/3/0
(scsi0) Wide Channel A, SCSI ID=7, 32/255 SCBs
(scsi0) Downloading sequencer code... 396 instructions downloaded
enable_irq() unbalanced from fc81baea
(scsi1) <Adaptec AIC-7899 Ultra 160/m SCSI host adapter> found at PCI 1/3/1
(scsi1) Wide Channel B, SCSI ID=7, 32/255 SCBs
(scsi1) Downloading sequencer code... 396 instructions downloaded
scsi0 : Adaptec AHA274x/284x/294x (EISA/VLB/PCI-Fast SCSI) 5.1.28/3.2.4
       <Adaptec AIC-7899 Ultra 160/m SCSI host adapter>
scsi1 : Adaptec AHA274x/284x/294x (EISA/VLB/PCI-Fast SCSI) 5.1.28/3.2.4
       <Adaptec AIC-7899 Ultra 160/m SCSI host adapter>
scsi : 2 hosts.
(scsi1:0:0:0) Synchronous at 160.0 Mbyte/sec, offset 63.
  Vendor: IBM-PSG   Model: ST318404LC    !#  Rev: 3146
  Type:   Direct-Access                      ANSI SCSI revision: 03
Detected scsi disk sda at scsi1, channel 0, id 0, lun 0
  Vendor: IBM       Model: YGLv3 S2          Rev: 0   
  Type:   Processor                          ANSI SCSI revision: 02
SCSI device sda: hdwr sector= 512 bytes. Sectors= 35548320 [17357 MB] [17.4 GB]
 sda: sda1 sda2 < sda5 sda6 sda7 sda8 sda9 sda10 sda11 >

Regards....Tim
Comment 5 Tim Clarke 2000-10-27 11:51:24 EDT
Do I need to change the status of this bug? Do you require further info?

Regards...Tim
Comment 6 Michael Fulbright 2000-10-27 16:11:21 EDT
Sorry - thanks for the information Tim.

I have not heard of this issue before, but it seems there is a problem with the
SCSI controllers.

Doug are there any known problems with these Adaptec controllers?
Comment 7 Michael Fulbright 2000-11-28 12:08:23 EST
Pleas reopen if you continue to have this problem.
Comment 8 Tim Clarke 2000-11-28 13:45:18 EST
Have I missed something. Are you waiting for further info from me?

Regards...Tim
Comment 9 Tim Clarke 2001-01-02 13:28:41 EST
I got the same failure today on a Netfinity 4500R using disks created from
RHBA-2000:010-01

Regards.....Tim
Comment 10 Tim Clarke 2001-01-08 13:12:22 EST
I got the same failure today on a Netfinity 4500R using disks created from
RHBA-2000:015-01.

Regards....Tim
Comment 11 Tim Clarke 2001-02-08 15:20:37 EST
Please close this problem. I managed to get this working by rebuilding the
kickstart file from scratch. I was referring to the RedHat 6.1 kickstart
docuentation whin I built the original config files and so was unaware of the
--onpart and --ondisk options on the part statements along with their
interaction with the clearpart and zerombr options.

Sorry to waste your time.

Regards...Tim
Comment 12 Tim Clarke 2001-02-13 15:45:02 EST
Although I have got this working with bootnet.img as supplied on my RedHat 6.2
CD, I have been unable to get past the "No Drives Found" message when using
bootnet-20000407.img along with the update-disk-20000419.img. It would be
preferable to use this image as it should incorporate the fix for setting an
encrypted root password, although the non-net version of this image appears to
fail to add an entry for the first ethernet adapter to conf.modules.

Regards....Tim
Comment 13 Michael Fulbright 2001-02-15 11:53:49 EST
Could you attach the kickstart file you are using with the updated 6.2 bootnet
image?
Comment 14 Tim Clarke 2001-02-15 15:12:57 EST
Created attachment 10120 [details]
kickstart file - ok with bootnet.img
Comment 15 Michael Fulbright 2001-04-02 11:43:36 EDT
Assigning to an engineer.
Comment 16 Brent Fox 2001-04-03 15:22:39 EDT
Do you have a conf.modules file at all after installation?
Comment 17 Tim Clarke 2001-04-05 09:18:10 EDT
Created attachment 14724 [details]
conf.modules created by RedHat 6.2 CD bootnet.img
Comment 18 Tim Clarke 2001-04-06 09:23:44 EDT
I do NOT get the "No Drives Found" failure when installing on a Dell Optiplex
GX110 system on my desktop using the bootnet-20000407.img. This system uses an
IDE controller for its disk.

Regards...Tim
Comment 19 Brent Fox 2001-04-11 12:06:53 EDT
Ok, this seems related to the Adaptec somehow.  If you try a regular,
non-kickstart install from a cd on the PowerEdge, does the same thing happen?
If so, can you go to VC2 and see if the aic7xxx module is even being loaded by
the kernel?
Comment 20 Tim Clarke 2001-04-12 11:05:34 EDT
If I use kickstart with bootnet.img supplied on RedHat 6.2 CD the install is
successful. If I use kickstart with bootnet-20000407.img I get the "No Drives
Found" error. A manual install from a CD on the PowerEdge completes
successfully.

I hope I have answered your question satisfactorily.

Regards...Tim
Comment 21 Brent Fox 2001-04-17 13:24:57 EDT
Ok, if you use kickstart with the bootnet-20000407.img, can you go to VC2 when
the "No Drives Found" error appears?  If so, can you run lsmod and see if the
aic7xxx driver is getting loaded.
Comment 22 Tim Clarke 2001-04-18 12:39:32 EDT
lsmod reveals that the driver is not loaded, and I did not see any attempt to
load it at the install screen. The sequence I am using is:-
1) insert bootnet-20000407.img in floppy drive
2) reboot machine
3) type "ks updates" at SYSLINUX prompt
4) insert update-disk-20000419.img floppy when prompted and hit enter
5) after 10 seconds or so I get "No Drives Found" dialog

Regards...Tim
Comment 23 Doug Ledford 2001-04-19 19:17:11 EDT
Since the problem is that this sequence of events doesn't even attempt to load
the aic7xxx module, it obviously isn't an aic7xxx issue, I'm removing myself
from the Cc: list.
Comment 24 Brent Fox 2001-04-21 19:03:43 EDT
Can you reproduce this with 7.0 or 7.1?
Comment 25 Tim Clarke 2001-04-23 05:25:49 EDT
Our main software package has not yet been validated with RedHat 7 so I haven't
really tried this yet. My feeling is that this failure is somehow related to the
sequence of events executed when using an update diskette.

Regards....Tim
Comment 26 Brent Fox 2001-04-23 14:46:59 EDT
There is the possibility that the aic7xxx driver was not on the updated bootnet
disk image.  Most people have had good experiences with 7.1 with the aic7xxx
driver.  I'm going to resolve this bug as 'Current Release'

Note You need to log in before you can comment on or make changes to this bug.