Bug 190457 - Hang when printing (ctrl+p)
Hang when printing (ctrl+p)
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-02 11:45 EDT by Kjartan Maraas
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-11 07:02:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
file that caused the hang (2.65 KB, text/plain)
2006-05-02 16:07 EDT, Kjartan Maraas
no flags Details

  None (edit)
Description Kjartan Maraas 2006-05-02 11:45:46 EDT
Description of problem:

I get this hang every time I press ctrl+p with the current development pacage of
firefox.

Version-Release number of selected component (if applicable):
firefox-1.5.0.2-4

Backtrace:

#0  0x00bcb402 in ?? ()
#1  0x00d8668c in ?? () from /lib/libpthread.so.0
#2  0x07b74393 in pt_TimedWait (cv=0x8901774, ml=0x8901710, timeout=Variable
"timeout" is not available.
)
    at ../../.././mozilla/nsprpub/pr/src/pthreads/ptsynch.c:280
#3  0x07b75224 in PR_WaitCondVar (cvar=0x8901770, timeout=60000)
    at ../../.././mozilla/nsprpub/pr/src/pthreads/ptsynch.c:407
#4  0x00f2ba7b in nsHostResolver::GetHostToLookup (this=0x89016b0,
result=0xb3618414) at nsHostResolver.cpp:556
#5  0x00f2c078 in nsHostResolver::ThreadFunc (arg=0x89016b0) at
nsHostResolver.cpp:641
#6  0x07b7b157 in _pt_root (arg=0x9382a78) at
../../.././mozilla/nsprpub/pr/src/pthreads/ptthread.c:220
#7  0x00d8341c in start_thread (arg=0xb3618ba0) at pthread_create.c:274
#8  0x00a71c5e in ?? () from /lib/libc.so.6
---Type <return> to continue, or q <return> to quit---

Thread 1 (Thread -1208387888 (LWP 16972)):
#0  0x00bcb402 in ?? ()
#1  0x00d89088 in ?? () from /lib/libpthread.so.0
#2  0x0292ec60 in httpGets (line=0xbf93d7c4 "", length=32768, http=0x933def8) at
/usr/include/bits/socket2.h:35
#3  0x0292ed87 in httpUpdate (http=0x933def8) at http.c:1654
#4  0x029403eb in cupsDoFileRequest (http=0x933def8, request=0x962b950,
resource=0x2948259 "/", filename=0x0)
    at request.c:250
#5  0x029407ee in cupsDoRequest (http=0x933def8, request=0x962b950,
resource=0x2948259 "/") at request.c:441
#6  0x02945b8c in cupsGetDefault2 (http=0x933def8) at util.c:433
#7  0x029282de in cupsGetDests2 (http=0x933def8, dests=0xbf95726c) at dest.c:500
#8  0x02928d1a in cupsGetDests (dests=0xbf95726c) at dest.c:415
#9  0x0098b31a in nsPSPrinterList::GetPrinterList (this=0xbf9572e8,
aList=@0xbf95730c) at nsPSPrinters.cpp:104
#10 0x0108bf3b in GlobalPrinters::InitializeGlobalPrinters (this=0x10c0810) at
nsDeviceContextSpecG.cpp:1340
#11 0x0108d1e8 in nsPrinterEnumeratorGTK::EnumeratePrinters (this=0x93d5228,
aCount=0x90f2ac4,
    aResult=0x90f2ac0) at nsDeviceContextSpecG.cpp:766
#12 0x032cff98 in nsPrinterListEnumerator::Init (this=0x90f2ab8) at
nsPrintOptionsImpl.cpp:204
#13 0x032cd908 in nsPrintOptions::AvailablePrinters (this=0x93e28e8,
aPrinterEnumerator=0xbf9573c0)
    at nsPrintOptionsImpl.cpp:931
#14 0x017355ec in nsPrintEngine::CheckForPrinters (this=0x93c3ac8,
aPrintOptions=0x93e28e8,
    aPrintSettings=0x922c6f0) at nsPrintEngine.cpp:1516
#15 0x0173955a in nsPrintEngine::Print (this=0x93c3ac8,
aPrintSettings=0x922c6f0, aWebProgressListener=0x0)
    at nsPrintEngine.cpp:584
#16 0x0165fbc6 in DocumentViewerImpl::Print (this=0x9073b88,
aPrintSettings=0x922c6f0, aWebProgressListener=0x0)
    at nsDocumentViewer.cpp:3360
#17 0x00188125 in XPTC_InvokeByIndex () at
../../../../../../dist/include/xpcom/xptcstubsdef.inc:251
#18 0x0102167c in XPCWrappedNative::CallMethod (ccx=@0xbf9577f4,
mode=XPCWrappedNative::CALL_METHOD)
    at xpcwrappednative.cpp:2152
#19 0x01024f98 in XPC_WN_CallMethod (cx=0x8bc6a00, obj=0x8c167b8, argc=2,
argv=0x92a6ab4, vp=0xbf9578f8)
---Type <return> to continue, or q <return> to quit---
    at xpcwrappednativejsops.cpp:1444
#20 0x00ca8f7d in js_Invoke (cx=0x8bc6a00, argc=2, flags=2) at jsinterp.c:1177
#21 0x00c9c9c5 in js_InternalInvoke (cx=0x8bc6a00, obj=0x8c167b8,
fval=146977120, flags=2, argc=2,
    argv=0x92a6a98, rval=0xbf957ab0) at jsinterp.c:1274
#22 0x00c79baa in JS_CallFunctionValue (cx=0x8bc6a00, obj=0x8c167b8,
fval=146977120, argc=2, argv=0x92a6a98,
    rval=0xbf957ab0) at jsapi.c:4171
#23 0x01028461 in XPC_NW_FunctionWrapper (cx=0x8bc6a00, obj=0x8c167c0, argc=2,
argv=0x92a6a98, rval=0xbf957b3c)
    at XPCNativeWrapper.cpp:373
#24 0x00ca8f7d in js_Invoke (cx=0x8bc6a00, argc=2, flags=0) at jsinterp.c:1177
#25 0x00ca3d77 in js_Interpret (cx=0x8bc6a00, pc=0x8bf2584 ":",
result=0xbf957e40) at jsinterp.c:3561
#26 0x00ca8fd4 in js_Invoke (cx=0x8bc6a00, argc=1, flags=2) at jsinterp.c:1197
#27 0x00c9c9c5 in js_InternalInvoke (cx=0x8bc6a00, obj=0x8c164d0,
fval=146892008, flags=2, argc=1,
    argv=0xbf958060, rval=0xbf958050) at jsinterp.c:1274
#28 0x00c79baa in JS_CallFunctionValue (cx=0x8bc6a00, obj=0x8c164d0,
fval=146892008, argc=1, argv=0xbf958060,
    rval=0xbf958050) at jsapi.c:4171
#29 0x0189ea84 in nsJSContext::CallEventHandler (this=0x8bb5d70,
aTarget=0x8c164d0, aHandler=0x8c164e8, argc=1,
    argv=0xbf958060, rval=0xbf958050) at nsJSEnvironment.cpp:1411
#30 0x018d3c61 in nsJSEventListener::HandleEvent (this=0x922ca08,
aEvent=0x93dc758) at nsJSEventListener.cpp:186
#31 0x0186f7af in nsXBLPrototypeHandler::ExecuteHandler (this=0x93ab4c0,
aReceiver=0x93dc7b0, aEvent=0x93dc758)
    at nsXBLPrototypeHandler.cpp:504
#32 0x0186cb93 in nsXBLWindowHandler::WalkHandlersInternal (this=0x8dbedcc,
aEvent=0x93dc758,
    aEventType=0x88de1e8, aHandler=0x93aa600) at nsXBLWindowHandler.cpp:305
#33 0x0186d410 in nsXBLWindowKeyHandler::WalkHandlers (this=0x8dbedc8,
aKeyEvent=0x93dc758,
    aEventType=0x88de1e8) at nsXBLWindowKeyHandler.cpp:193
#34 0x0186ce79 in nsXBLWindowKeyHandler::KeyPress (this=0x8dbedc8,
aKeyEvent=0x93dc758)
    at nsXBLWindowKeyHandler.cpp:248
#35 0x017e0b05 in nsEventListenerManager::HandleEvent (this=0x8d810c0,
aPresContext=0x90f4730,
    aEvent=0xbf9595f4, aDOMEvent=0xbf9592e0, aCurrentTarget=0x8ce54f0,
aFlags=514, aEventStatus=0xbf959484)
    at nsEventListenerManager.cpp:141
---Type <return> to continue, or q <return> to quit---
#36 0x0188af77 in nsXULDocument::HandleDOMEvent (this=0x8ce5440,
aPresContext=0x90f4730, aEvent=0xbf9595f4,
    aDOMEvent=0xbf9592e0, aFlags=514, aEventStatus=0xbf959484) at
nsXULDocument.cpp:1246
#37 0x0187a9ac in nsXULElement::HandleDOMEvent (this=0x8d811a8,
aPresContext=0x90f4730, aEvent=0xbf9595f4,
    aDOMEvent=0xbf9592e0, aFlags=514, aEventStatus=0xbf959484) at
nsXULElement.cpp:2179
#38 0x0187a974 in nsXULElement::HandleDOMEvent (this=0x8dcf150,
aPresContext=0x90f4730, aEvent=0xbf9595f4,
    aDOMEvent=0xbf9592e0, aFlags=514, aEventStatus=0xbf959484) at
nsXULElement.cpp:2173
#39 0x0187a974 in nsXULElement::HandleDOMEvent (this=0x8dcf738,
aPresContext=0x90f4730, aEvent=0xbf9595f4,
    aDOMEvent=0xbf9592e0, aFlags=514, aEventStatus=0xbf959484) at
nsXULElement.cpp:2173
#40 0x0187a974 in nsXULElement::HandleDOMEvent (this=0x8dcf7e0,
aPresContext=0x90f4730, aEvent=0xbf9595f4,
    aDOMEvent=0xbf9592e0, aFlags=514, aEventStatus=0xbf959484) at
nsXULElement.cpp:2173
#41 0x0187a974 in nsXULElement::HandleDOMEvent (this=0x8ec8698,
aPresContext=0x90f4730, aEvent=0xbf9595f4,
    aDOMEvent=0xbf9592e0, aFlags=514, aEventStatus=0xbf959484) at
nsXULElement.cpp:2173
#42 0x0187a974 in nsXULElement::HandleDOMEvent (this=0x8e9a960,
aPresContext=0x90f4730, aEvent=0xbf9595f4,
    aDOMEvent=0xbf9592e0, aFlags=514, aEventStatus=0xbf959484) at
nsXULElement.cpp:2173
#43 0x0187a974 in nsXULElement::HandleDOMEvent (this=0x8e9a9e0,
aPresContext=0x90f4730, aEvent=0xbf9595f4,
    aDOMEvent=0xbf9592e0, aFlags=514, aEventStatus=0xbf959484) at
nsXULElement.cpp:2173
#44 0x0187a974 in nsXULElement::HandleDOMEvent (this=0x8e9aaa0,
aPresContext=0x90f4730, aEvent=0xbf9595f4,
    aDOMEvent=0xbf9592e0, aFlags=514, aEventStatus=0xbf959484) at
nsXULElement.cpp:2173
#45 0x018760bb in nsXULElement::HandleChromeEvent (this=0x8e9aaa0,
aPresContext=0x90f4730, aEvent=0xbf9595f4,
    aDOMEvent=0xbf9592e0, aFlags=514, aEventStatus=0xbf959484) at
nsXULElement.cpp:2834
#46 0x018b0ac7 in nsGlobalWindow::HandleDOMEvent (this=0x90c2b68,
aPresContext=0x90f4730, aEvent=0xbf9595f4,
    aDOMEvent=0xbf9592e0, aFlags=514, aEventStatus=0xbf959484) at
nsGlobalWindow.cpp:1625
#47 0x017aad63 in nsDocument::HandleDOMEvent (this=0x9073298,
aPresContext=0x90f4730, aEvent=0xbf9595f4,
    aDOMEvent=0xbf9592e0, aFlags=514, aEventStatus=0xbf959484) at
nsDocument.cpp:4056
#48 0x017bf05a in nsGenericElement::HandleDOMEvent (this=0x9052b28,
aPresContext=0x90f4730, aEvent=0xbf9595f4,
    aDOMEvent=0xbf9592e0, aFlags=519, aEventStatus=0xbf959484) at
nsGenericElement.cpp:2206
#49 0x0166d411 in PresShell::HandleEventInternal (this=0x9139290,
aEvent=0xbf9595f4, aView=0x900a208,
    aFlags=513, aStatus=0xbf959484) at nsPresShell.cpp:6427
#50 0x01675efd in PresShell::HandleEvent (this=0x9139290, aView=0x900a208,
aEvent=0xbf9595f4,
---Type <return> to continue, or q <return> to quit---
    aEventStatus=0xbf959484, aForceHandle=1, aHandled=@0xbf959480) at
nsPresShell.cpp:6210
#51 0x018963ef in nsViewManager::HandleEvent (this=0x900a0d8, aView=0x900a208,
aEvent=0xbf9595f4, aCaptured=0)
    at nsViewManager.cpp:2512
#52 0x0189a091 in nsViewManager::DispatchEvent (this=0x900a0d8,
aEvent=0xbf9595f4, aStatus=0xbf959574)
    at nsViewManager.cpp:2246
#53 0x01891b40 in HandleEvent (aEvent=0xbf9595f4) at nsView.cpp:171
#54 0x00c40294 in nsCommonWidget::DispatchEvent (this=0x900d370,
aEvent=0xbf9595f4, aStatus=@0xbf95968c)
    at nsCommonWidget.cpp:219
#55 0x00c3b210 in nsWindow::OnKeyPressEvent (this=0x900d370, aWidget=0x8afb908,
aEvent=0x88c0780)
    at nsWindow.cpp:1785
#56 0x00c3b36f in key_press_event_cb (widget=0x8afb908, event=0x88c0780) at
nsWindow.cpp:3876
#57 0x003085ae in _gtk_marshal_BOOLEAN__BOXED (closure=0x8bb5fa8,
return_value=0xbf959810, n_param_values=2,
    param_values=0xbf9598ec, invocation_hint=0xbf9597fc, marshal_data=0xc3b31e)
at gtkmarshalers.c:83
#58 0x00667f7b in IA__g_closure_invoke (closure=0x8bb5fa8,
return_value=0xbf959810, n_param_values=2,
    param_values=0xbf9598ec, invocation_hint=0xbf9597fc) at gclosure.c:490
#59 0x00678a3d in signal_emit_unlocked_R (node=0x89ae5c0, detail=0,
instance=0x8afb908,
    emission_return=0xbf959aac, instance_and_params=0xbf9598ec) at gsignal.c:2438
#60 0x00679d0f in IA__g_signal_emit_valist (instance=0x8afb908, signal_id=34,
detail=0, var_args=Variable "var_args" is not available.
)
    at gsignal.c:2207
#61 0x0067a109 in IA__g_signal_emit (instance=0x8afb908, signal_id=34, detail=0)
at gsignal.c:2241
#62 0x003f3868 in gtk_widget_event_internal (widget=0x8afb908, event=0x88c0780)
at gtkwidget.c:3751
#63 0x00402be7 in IA__gtk_window_propagate_key_event (window=0x8a6f030,
event=0x88c0780) at gtkwindow.c:4517
#64 0x00405a3c in gtk_window_key_press_event (widget=0x8a6f030, event=0x88c0780)
at gtkwindow.c:4547
#65 0x003085ae in _gtk_marshal_BOOLEAN__BOXED (closure=0x89ae4c8,
return_value=0xbf959d30, n_param_values=2,
    param_values=0xbf959e0c, invocation_hint=0xbf959d1c, marshal_data=0x4059f0)
at gtkmarshalers.c:83
#66 0x006667a9 in g_type_class_meta_marshal (closure=0x89ae4c8,
return_value=0xbf959d30, n_param_values=2,
    param_values=0xbf959e0c, invocation_hint=0xbf959d1c, marshal_data=0xcc) at
gclosure.c:567
#67 0x00667f7b in IA__g_closure_invoke (closure=0x89ae4c8,
return_value=0xbf959d30, n_param_values=2,
    param_values=0xbf959e0c, invocation_hint=0xbf959d1c) at gclosure.c:490
---Type <return> to continue, or q <return> to quit---
#68 0x00679083 in signal_emit_unlocked_R (node=0x89ae5c0, detail=0,
instance=0x8a6f030,
    emission_return=0xbf959fcc, instance_and_params=0xbf959e0c) at gsignal.c:2476
#69 0x00679d0f in IA__g_signal_emit_valist (instance=0x8a6f030, signal_id=34,
detail=0, var_args=Variable "var_args" is not available.
)
    at gsignal.c:2207
#70 0x0067a109 in IA__g_signal_emit (instance=0x8a6f030, signal_id=34, detail=0)
at gsignal.c:2241
#71 0x003f3868 in gtk_widget_event_internal (widget=0x8a6f030, event=0x88c0780)
at gtkwidget.c:3751
#72 0x00301fba in IA__gtk_propagate_event (widget=0x8a6f030, event=0x88c0780) at
gtkmain.c:2169
#73 0x003031d7 in IA__gtk_main_do_event (event=0x88c0780) at gtkmain.c:1424
#74 0x005b688a in gdk_event_dispatch (source=0x88c3898, callback=0,
user_data=0x0) at gdkevents-x11.c:2291
#75 0x006c311d in IA__g_main_context_dispatch (context=0x88c38e0) at gmain.c:1916
#76 0x006c63af in g_main_context_iterate (context=0x88c38e0, block=1,
dispatch=1, self=0x89bab28)
    at gmain.c:2547
#77 0x006c6759 in IA__g_main_loop_run (loop=0x8cdf4a8) at gmain.c:2751
#78 0x00303654 in IA__gtk_main () at gtkmain.c:1003
#79 0x00c3efc8 in nsAppShell::Run (this=0x89dc658) at nsAppShell.cpp:139
#80 0x0339341e in nsAppStartup::Run (this=0x89dc618) at nsAppStartup.cpp:150
#81 0x0804f40f in XRE_main (argc=1, argv=0xbf95a734, aAppData=0x8063420) at
nsAppRunner.cpp:2351
#82 0x0804af75 in main (argc=1, argv=0xbf95a734) at nsBrowserApp.cpp:61
#83 0x009bf824 in __libc_start_main (main=0x804af54 <main>, argc=1,
ubp_av=0xbf95a734,
    init=0x8058584 <__libc_csu_init>, fini=0x805857c <__libc_csu_fini>,
rtld_fini=0xbd9f00 <_dl_fini>,
    stack_end=0xbf95a72c) at libc-start.c:231
#84 0x0804aed1 in _start ()

How reproducible:
Every time

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Chris Ball 2006-05-02 12:03:37 EDT
Not reproduced with Rawhide here.  Maybe you should check that other CUPS-using
apps bring up a print dialog okay, to check it isn't a CUPS problem?
Comment 2 Kjartan Maraas 2006-05-02 16:07:24 EDT
Created attachment 128515 [details]
file that caused the hang
Comment 3 Tim Waugh 2006-05-16 10:31:04 EDT
I can't reproduce this here.  What version of cups and cups-libs are you
running?  Also, what does 'lpstat -s' say, etc?
Comment 4 Martin Stransky 2007-09-11 07:02:12 EDT
Unable to reproduce, closing.

Note You need to log in before you can comment on or make changes to this bug.