Bug 190490 - Anaconda allows installation from wrong architecture tree
Anaconda allows installation from wrong architecture tree
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-02 17:00 EDT by Aleksandar Milivojevic
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-15 13:57:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aleksandar Milivojevic 2006-05-02 17:00:03 EDT
Description of problem:
Let say I'm doing network installation and my directory tree on install server
looks like this:

/install/rhel4/os/i386
/install/rhel4/os/x86_64

Now, if I use x86_64 CD/DVD to boot, but by mistake point Anaconda to i386 tree,
it will happily install OS from i386 tree.  Not really sure if this should be
allowed.  If nothing else, it could easilly break postinstall script that might
detect they are being run on 64-bit system (which in turn can play havoc on the
final installation).

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 David Cantrell 2007-03-15 13:57:28 EDT
That is how multilib works in RPM.  Can't fix this.

Note You need to log in before you can comment on or make changes to this bug.