Bug 190492 - Using clamd-wrapper leads to many rpmlint errors
Using clamd-wrapper leads to many rpmlint errors
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: clamav (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Enrico Scholz
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 181450
  Show dependency treegraph
 
Reported: 2006-05-02 17:11 EDT by Orion Poplawski
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-27 17:09:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2006-05-02 17:11:34 EDT
Description of problem:

I'm reviewing Tim Jackson's clamav-exim package (Bug 181450).  It uses the
clamd-wrapper init system from clamav-server.  However, it leads to a number of
rpmlint errors trying to enforce a naming convention for packages:

E: clamav-exim incoherent-logrotate-file /etc/logrotate.d/clamd.exim
Your logrotate file should be named /etc/logrotate.d/<package name>.

W: clamav-exim incoherent-init-script-name clamd.exim
The init script name should be the same as the package name in lower case.

Note that "." can't be in the package name.

Now, I'm not convinced that clamd-wrapper should be used at all by other FE
packages.  But, if we do want to use it, it needs to be changed so that we end
up following FE naming convetions.

Also, not sure what server packages should be called:

clamav-<servername>
clamav-server-<servername>
clad-<servername>
clad-server-<servername>
Comment 1 Tim Jackson 2006-08-05 19:22:19 EDT
ping on this bug; Enrico, any comments? Your opinions would be very much
appreciated.
Comment 2 David Woodhouse 2006-09-12 12:17:07 EDT
It's painful for any other Extras package to use the clamd-wrapper stuff.

I think the best way is to have the separate dæmon configurations done as
subpackages of clamav -- or better still, to have a clamav-server setup which is
capable of starting multiple dæmons rather than having to have separate
initscripts, logrotate configurations, etc. 
Comment 3 Orion Poplawski 2007-03-27 17:09:56 EDT
I'm closing this due to an apparent lack of interest.  There don't seem to be
any other external clamav daemons at the moment.

Note You need to log in before you can comment on or make changes to this bug.