Bug 19050 - Installation crashes during formatting of /.
Installation crashes during formatting of /.
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-13 10:38 EDT by Tony Kocurko
Modified: 2008-01-30 16:24 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-14 17:54:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tony Kocurko 2000-10-13 10:38:27 EDT
Hello,

After having gotten through the installation up to the point when the disk
is to be formatted, we get this pop-up window:

  Formatting / filesystem...

Soon afterwards, the system crashes with the following text, shown between
the lines of "===="s, displayed on the screen. Details of our configuration
follow this text. (I have included some typical "\" continuation formatting
in order to avoid ugly line wrapping.) The problem appears to have occured
in the mke2fs process, but you'll see that in the text below.

===========================================================================
  Unable to handle kernel NULL pointer dereference at \
    virtual address 00000000
  current->tss.cr3 = 1fe5f000, %cr3 = 1fe5f000
  *pde = 00000000
  Oops: 0002
  CPU:    0
  EIP:    0010:[<c011f665]
  EFLAGS: 00010286
  eax: 0000003d   ebx: d9e76e00   ecx: 00000000   edx: dfec8000
  esi: dfed1740   edi: 00000286   epb: 00000009   esp: df427c48
  ds: 0018   es: 0018   ss: 0018
  Process mke2fs (pid: 38, process nr: 12, stackpage=df427000)
  Stack: d9e76ef0 c067e0b8 d9e76e4c d9e0afb0 c0125729 dfed1740 d9e76e00 \
              d9376e00
         d9e76ef0 c012647b d9e76e00 d9e76e00 c067e0b8 000007fa 00000005 \
              00000301
         c011b432 c067e0b8 0000000f 00000006 c01202ca 00000006 00000005 \
              00000001
  Call Trace: [<c0125729>] [<c012647b>] [<c011b432>] [<c01202ca>] \
                           [<c01203e8>] [<c0120b8b>] [<c012637d>]
              [<c01251d5>] [<c012537e>] [<c01280e7>] [<c01cc84e>] \
                           [<c016e135>] [<c0185073>] [<c0185684>] \
                           [<c0124f1f>]
              [<c013a5e0>] [<c018cb5b>] [<c018c8ef>] [<c018d255>] \
                           [<c018d154>] [<c01929e8>] [<c018d179>] \
                           [<c018d255>]
              [<c01947ab>] [<c01905a8>] [<c0194638>] [<c0123b3a>] \
                           [<c0127f40>] [<c0107aac>]

  Code: c7 05 00 00 00 00 00 00 00 00 eb 0f 56 53 68 9e 37 1d c0 e8

  kmem_free: Bad obj addr (objp=d9ee2f70, name=buffer_head)
===========================================================================


Our configuration is a bit exotic in one respect only: We have two Promise
Ultra100 PCI cards installed. Otherwise, the system is fairly generic:

 1. CPU         = 733 MHz Pentium III 133 FSB FC-PGA
 2. Motherboard = Asus CUSL2
 3. Memory      = 512 MB
 4. Hard Drive  = Western Digital Caviar 14300 EIDE jumpered as master
                  on motherboard primary IDE port
 5. CD          = Hewlett-Packard CD-Writer Plus 8100i jumpered as slave
                  on motherboard primary IDE port
 6. Floppy      = none
 7. Graphics    = On-board Intel 815e VGA graphics connector
 8. Monitor     = AST SVGA-LR
 9. Hard Drives = 2 Promise Technology Ultra100 ATA/100 cards with a total
                  of 3 Maxtor Diamond Max80 80 GB drives on each, two on
                  one channel, and one on the other. Note, though, that
                  only the motherboard sees these six drives, since their
                  drivers are not loaded by the Linux "install" kernel.
10. NIC         = 3Com905TN, but we're not yet connected to the net.

Any ideas?

Cheers,
Tony Kocurko - Memorial University of Newfoundland
Comment 1 Alan Cox 2000-10-14 17:54:44 EDT
This is typically an indication of bad hardware, but as always its never
definitively that. I suspect its a memory/cpu issue. I've reassigned it to
kernel as if its not hardware thats where the problem will lie.
Comment 2 Tony Kocurko 2000-10-16 09:21:07 EDT
Please delete this bug, or mark it as resolved.

The problem seems to be caused by my having had the CD drive as slave to the
hard drive master on a single IDE port. Once, I moved the CD to the master
role on the secondary IDE port, leaving the hard drive as master on the
primary IDE port, the problem went away.

There is a new problem, however, which I will investigate further before
submitting a report.

Note You need to log in before you can comment on or make changes to this bug.