Bug 190503 - root-on-LVM fsck fails because / mounted without -o ro
Summary: root-on-LVM fsck fails because / mounted without -o ro
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Peter Jones
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-05-03 00:19 UTC by Alexandre Oliva
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 5.0.37-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-09 15:21:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch that fixes teh bug (885 bytes, patch)
2006-05-03 00:19 UTC, Alexandre Oliva
no flags Details | Diff

Description Alexandre Oliva 2006-05-03 00:19:52 UTC
Created attachment 128529 [details]
Patch that fixes teh bug

Comment 1 Alexandre Oliva 2006-05-03 00:19:52 UTC
Description of problem:
The recent reworking of mkinitrd to better support NFS root broke root on LVM
(or rather root without LABEL= in /etc/fstab), since rootopts is not edited
properly so as to contain ro (unless /etc/fstab is supposed to contain it
explicitly; in my case it does not)

Version-Release number of selected component (if applicable):
mkinitrd-5.0.36-1

How reproducible:
Every time

Steps to Reproduce:
1.List / in /etc/fstab without LABEL= and without ro in the mount options
2.Run mkinitrd
3.Verify that initrd.img's init script doesn't mount root with ro
4.Boot into it
  
Actual results:
fsck fails to check the root filesystem because it's already mounted read-write

Expected results:
It should have been mounted read-only

Additional info:
The attached patch uses an uglyish shell idiom to avoid duplicating the sed command.

Comment 2 Bill Nottingham 2006-05-09 15:21:21 UTC
This is fixed in 5.0.37-1.


Note You need to log in before you can comment on or make changes to this bug.