Bug 190511 - 'yum -c' doesn't work with http url
Summary: 'yum -c' doesn't work with http url
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
(Show other bugs)
Version: 5
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
: 197023 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-05-03 03:42 UTC by Ian Mortimer
Modified: 2014-01-21 22:54 UTC (History)
2 users (show)

Fixed In Version: fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-31 00:33:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ian Mortimer 2006-05-03 03:42:37 UTC
Description of problem:
According to the yum man page 'yum -c' can specify a local file or a
http or ftp url as the location of the config file.  This has always
worked with previous releases but with FC5 it fails.


Version-Release number of selected component (if applicable):
2.6.0-1

How reproducible:
always


Steps to Reproduce:
1. put a yum config file on a web server
2. yum -c http://web.server/path/to/yum.conf
3.
  
Actual results:
yum reports:

Config Error: No such config file http://...

Expected results:
Yum should fetch the config file from the web server.


Additional info:
wget fetches the config file from the same URL so the problem is
not with the URL or the web server.

tcpdump on the web server doesn't show any connection from the
client which indicates yum isn't trying to fetch it as a URL
but looking for it as a file.

when I created a directory with the path http://... and copied the
yum.conf file into that directory 'yum -c http://...' worked.  
Indicates that yum is treating the URL as a path.

Comment 1 Seth Vidal 2006-05-03 13:34:02 UTC
I'll take a look at this.


Comment 2 Jeremy Katz 2006-09-18 20:51:42 UTC
*** Bug 197023 has been marked as a duplicate of this bug. ***

Comment 3 Ian Mortimer 2006-10-30 23:59:12 UTC
Fixed in FC6.  yum-3.0-6.

Comment 4 Jeremy Katz 2006-10-31 00:33:03 UTC
Yep, thanks for updating the bug and confirming!

Comment 5 Michal Jaegermann 2006-10-31 16:12:56 UTC
Well, FC5 is as broken as it was.  Just had a nasty encounter with
this issue.


Note You need to log in before you can comment on or make changes to this bug.