Bug 190541 - 4.1.0-12: 32-bit gcc package requires 64-bit libraries
Summary: 4.1.0-12: 32-bit gcc package requires 64-bit libraries
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: powerpc Linux
medium
urgent
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-05-03 13:40 UTC by Joseph Sacco
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version: 4.1.0-13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-05 13:51:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joseph Sacco 2006-05-03 13:40:08 UTC
4.1.0-12: 32-bit gcc package requires 64-bit libraries

Discovered the problem when running yum update' problem on a 32-bit PowerMac.
The transaction check fails, complaining about missing 64-bit dependencies:

 Error: Missing Dependency: libgomp.so.1()(64bit) is needed by package gcc
 Error: Missing Dependency: libgfortran.so.1()(64bit) is needed by package
gcc-gfortran
Error: Missing Dependency: libstdc++.so.6()(64bit) is needed by package gcc-c++

-Joseph

Comment 1 John Ellson 2006-05-03 14:52:14 UTC
Also, the 64-bit gcc packages now have a new dependency on the 32 bit libraries.




Comment 2 Jon Masters 2006-05-03 19:33:08 UTC
I am having exactly the same issue here today.

Comment 3 Jakub Jelinek 2006-05-05 07:47:17 UTC
Should be fixed in gcc-4.1.0-13.  It was caused by the rpm requires generation
changes.

Comment 4 Jon Masters 2006-05-05 13:37:31 UTC
I can install the new gcc package, but trying to do a "yum update" causes things
to bomb out with the following warning, immediately after processing gcc:

python: rpmte.c:589 rpmteColorDS: Assertion `ix < Count' failed.

Comment 5 Jakub Jelinek 2006-05-05 13:51:36 UTC
That's a rpm bug on a different package, so why are you reopening this bug?


Note You need to log in before you can comment on or make changes to this bug.