Bug 190546 - User Manager (in kde?) deletes homes when new user added
User Manager (in kde?) deletes homes when new user added
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: system-config-users (Show other bugs)
5
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Nils Philippsen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-03 10:29 EDT by David W. Legg
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 07:49:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David W. Legg 2006-05-03 10:29:07 EDT
Description of problem:
Using the KDE User Manager gui tool as root on a fully updated FC5 as of
2/5/2006.  When I added a fresh user, all my other users' home directories were
deleted.

Version-Release number of selected component (if applicable):
Not sure if this is kdeadmin or not.  The window was definitely called 'user
Manager'. I was using it under KDE.

How reproducible:
Daren't risk it!

Steps to Reproduce:
1. Log in under KDE as root.
2. Select Users and Groups from menu.
3. Add user called guest with name 'Guest'.
4. Specify userid=503, taking all other defaults.
5. Enter password.
  
Actual results:
/home/guest not created
/home/daddy etc all deleted (nasty!)

Expected results:
/home/guest created
/home/daddy all intact.

Additional info:
Comment 1 David W. Legg 2006-05-03 10:51:32 EDT
Just realised, it's system-config-users that did the damage, nto kdeadmin.
Comment 2 Nils Philippsen 2006-05-04 07:04:08 EDT
Hm, I'm a bit doubtful about that one. Namely because I just created a user
(with  a specified userid of 503) which somehow didn't delete anything, only
created the user's home directory. Afterwards I deleted the user, which removed
the home dir, mail spool and (non-existent) temporary files -- and nothing else.

The "remove stuff" parts will only be executed when deleting a user (just
checked the code) so I really don't know why s-c-users should delete _anything_
when creating a user.

Now one difference is that you did this under KDE while I use GNOME, but
s-c-users should be pretty agnostic of the used desktop environment...
Comment 3 David W. Legg 2006-05-04 12:20:15 EDT
I did it on an x86_64 machine. Was yours x86_64?
The problem is that it's a bit drastic to experiment with on a live machine.
Comment 4 Nils Philippsen 2006-05-05 11:28:09 EDT
s-c-users is platform independent (it's written in python). Which version of
s-c-users are you using anyway?
Comment 5 David W. Legg 2006-05-05 14:43:08 EDT
system-config-users-1.2.42-1

Why not leave this bug report lying around for a while.
Then when some-one else confirms it, you will have confirmation.
Even so, there was no way I could have accidentally done an rm -rf /home/*
whilst using system-config-users.
Comment 6 Nils Philippsen 2007-02-01 11:24:25 EST
Just going through my open bugs -- it seems nobody else experienced this (I
didn't get other bug reports for this).

I've added the libuser maintainer to Cc.

Mirek, do you have an idea? I mean I'm pretty sure there is nothing in s-c-users
or libuser that could cause this...
Comment 7 David W. Legg 2007-02-02 11:51:38 EST
Has anyone tried adding a new user with a new user name, but 'accidentally'
setting the UID (i.e. 501 or something) to be that of an existing user?
Maybe I originally did something daft like that?
Even if I did, it is undesirable behaviour :(
Comment 8 Nils Philippsen 2007-02-05 06:33:55 EST
I've tried this with current CVS, it catches this kind of error (and has been
doing so for a long time).
Comment 9 Miloslav Trmač 2007-02-12 12:47:42 EST
I have checked both libuser and s-c-users and I can't find anything either, I'm
afraid.

Note You need to log in before you can comment on or make changes to this bug.