Bug 190562 - totem error with ogg theora files
totem error with ogg theora files
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: totem (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-03 12:14 EDT by Ronny Fischer
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-27 08:36:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ronny Fischer 2006-05-03 12:14:15 EDT
Description of problem:

Trying to play ogg theora videos (demos from the aiglx rendering project) 
results in an error saying:
"internal data flow error"

Version-Release number of selected component (if applicable):

Kernel 2.6.16-1.2096, totem 1.4.0 with gstreamer 0.10.5

How reproducible:

always
Steps to Reproduce:
1.open an ogg theora video file with totem
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Ronny Fischer 2006-05-03 16:31:03 EDT
when trying to open the file via the command line with "totem file.ogg" there 
appears following message:

** (totem:3216): WARNING **: Trying to connect to an older version of the GNOME 
screensaver

(totem:3216): GStreamer-CRITICAL **: gst_event_new_new_segment: assertion `start
 != -1' failed
Comment 2 John Thacker 2006-05-04 08:38:16 EDT
Hmm, I can't duplicate this.

First off, does the video play as normal, besides the error, or does it crash or
otherwise fail to play the file?

The first warning is just about connecting to GNOME screensaver in order to
disable it.  Do you have gnome-screensaver enabled, or are you using
xscreensaver?  What version of gnome-screensaver is installed?
Comment 3 Ronny Fischer 2006-05-04 14:33:26 EDT
Hello

the file doesn't play anyway. When I try to open it, totem seems to load the 
digital stream from the file but when the video should start playing, the error 
message occurs and the screen remains black. The package for decoding those 
files is installed (libtheora-mmx).

I have xscreensaver-base and xscreensaver-gl-extras installed and enabled 
(version 4.24-2) but disabling it doesn't resolve the problem.

I'm not sure if it is important, but I have installed packages from "gstreamer 
freedesktop project".

I can play other files with totem without problems (mpg, avi, even some wmv 
files) so I'm wondering about it. For those I can have a preview of the content 
(diplaying a still image from within the movie) in nautilus file manager, but 
not for ogg theora files.

Thanks to you for help.
Comment 4 W. Michael Petullo 2006-05-14 19:19:43 EDT
I am also having trouble playing Ogg Theora files.

I am using gstreamer-plugins-base-0.10.5-1 on a PowerPC iBook.

When I load an Ogg Theora file using totem, the following is printed to my console:

(totem:2666): GStreamer-CRITICAL **: gst_bin_add: assertion `GST_IS_ELEMENT
(element)' failed

(totem:2666): GStreamer-CRITICAL **: gst_element_link_pads: assertion
`GST_IS_ELEMENT (dest)' failed

(totem:2666): GStreamer-CRITICAL **: gst_element_link_pads: assertion
`GST_IS_ELEMENT (src)' failed

Totem starts, but the video screen remains blank.  Totem's clock remains at
0:00/6:58.  Other than that, totem is operational (i.e.: it has not hung.)

If I try to play the same video using "gst-launch playbin...," is see:

(gst-launch-0.10:2737): GStreamer-CRITICAL **: gst_bin_add: assertion
`GST_IS_ELEMENT (element)' failed

(gst-launch-0.10:2737): GStreamer-CRITICAL **: gst_element_link_pads: assertion
`GST_IS_ELEMENT (dest)' failed

(gst-launch-0.10:2737): GStreamer-CRITICAL **: gst_element_link_pads: assertion
`GST_IS_ELEMENT (src)' failed

In this scenario, gst-launch never produces an X11 window.

Other file formats work fine.
Comment 5 Bastien Nocera 2006-10-27 05:39:25 EDT
Michael, Ron, do you still get the same problem with FC6?
Comment 6 Ronny Fischer 2006-10-27 07:13:02 EDT
Hi there

the problem still remains in FC6. I actually have installed totem player from 
Core and some codecs from livna (ffmpeg, xvid-core, xine-lib etc.)

Its same as described before, the player wants to open the file and shuts down 
immediatly.

Opening the file via command line with "totem shot03.ogg" following error 
occurs:

The program 'totem' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 85 error_code 11 request_code 140 minor_code 19)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

As before, other file formats such as avi or mpeg work correctly.
Comment 7 Bastien Nocera 2006-10-27 08:26:23 EDT
Could you please get the output of 
xvinfo | grep "maximum XvImage"
?

Could you also tell me the resolution of the video file (you can right click on
the file to see that in the "audio/video" tab)?

The bug isn't the same as the original one though...
Comment 8 Ronny Fischer 2006-10-27 09:30:20 EDT
output of xvinfo | grep "maximum XvImage" is

maximum XvImage size: 1920 x 1080
maximum XvImage size: 2048 x 2048

the file resolution ist 1024 x 768 at 15 Frames per second with theora codec.
Comment 9 Bastien Nocera 2006-11-27 05:37:02 EST
Could you double-check in the about box that you're using the GStreamer backend?
If not, you'll need to file the bug at livna, or upstream, as Fedora doesn't
ship totem-xine.
Comment 10 Ronny Fischer 2006-11-27 07:42:48 EST
Hmm, strange. As you supposed, I used totem with xine-libs. I replaced totem-
xine with the regular totem player and it worked. After reinstalling totem-xine 
it works, too.

Guess this bug can be closed.

Comment 11 Bastien Nocera 2006-11-27 08:36:44 EST
Thanks.

Note You need to log in before you can comment on or make changes to this bug.