Bug 190578 - after upgrade to kernel 2.6.16-1.2107_FC5 cups hangs when printing
after upgrade to kernel 2.6.16-1.2107_FC5 cups hangs when printing
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-03 14:59 EDT by Sven
Modified: 2015-01-04 17:26 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-06 20:07:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sven 2006-05-03 14:59:30 EDT
Description of problem:

after upgrade to kernel 2.6.16-1.2107_FC5 cups hangs when printing (only tested
with networked printer - samba and lpd)

I can list, add and remove printers but can not print, also when I try to print
from a program (ex: evince) it hangs. In openoffice no printers are show.

If I boot with an older kernel (2.6.16-1.2096_FC5) everything works


Version-Release number of selected component (if applicable):
hal-cups-utils-0.5.5-1.2
cups-libs-1.1.23-30.2
cups-lpd-1.1.23-30.2
cups-1.1.23-30.2
gimp-print-cups-4.2.7-16
libgnomecups-0.2.2-3.2.1


How reproducible:
always

Steps to Reproduce:
1. define a cups printer
2. boot with kernel 2.6.16-1.2107_FC5
3.
  
Actual results:
No printing

Expected results:
printing

Additional info:
Comment 1 Sergio Monteiro Basto 2006-05-03 15:19:41 EDT
yap , I have a problem with cups also after upgrade to 2107
using printconf can't apply any change, because never ends applying changes.
this happens only with service cups started .
I try a strace printconf 
and stops on  waitpid(3936, 
3936  3928  0 20:24 pts/1    00:00:00 sh -c /sbin/service cups reload >/dev/null
2>/dev/null
root      3937  3936  0 20:24 pts/1    00:00:00 /bin/sh /sbin/service cups reload
root      3940  3937  0 20:24 pts/1    00:00:00 /bin/sh /etc/init.d/cups reload
root      3943  3940  0 20:24 pts/1    00:00:00 /usr/bin/python -O
/usr/sbin/printconf-backend
root      3954  3943  0 20:24 pts/1    00:00:00 sh -c /usr/bin/lpoptions -d
$DEFAULT >/dev/null 2>/dev/null
root      3955  3954  0 20:24 pts/1    00:00:00 /usr/bin/lpoptions -d laserjet4250

just after kill 3936 , the changes are applied 
Comment 2 Sergio Monteiro Basto 2006-05-03 15:27:55 EDT
some more information:
the problem is with 
/usr/bin/lpoptions -d laserjet4250 that hangs ! 
Comment 3 Jared Smith 2006-05-03 18:01:20 EDT
Interesting... for me (on two different machines, one ppc and one x86_64) CUPS
hangs on boot with the 2.6.16-1.2107_FC5 kernel.  If I boot back to a previous
kernel, it works just fine.  Based on other bug reports for this kernel
(#190586, #190606), it sounds like htis kernel has some issues.
Comment 4 Dave Jones 2006-05-03 23:36:17 EDT
does booting with pci=nomsi make this go away?
Comment 5 Dave Jones 2006-05-04 00:12:10 EDT
Actually, that option is also broken in this kernel (sigh).

2108, available from http://people.redhat.com/davej/kernels/Fedora/FC5/
has this disabled by default. Give that a try ?
Comment 6 Mogens Kjaer 2006-05-04 06:06:11 EDT
For me:

2096: lpr works
2107: lpr hangs
2108: lpr hangs
2108 pci=nomsi: lpr hangs
Comment 7 Sven 2006-05-04 06:37:21 EDT
(In reply to comment #5)
> Actually, that option is also broken in this kernel (sigh).
> 
> 2108, available from http://people.redhat.com/davej/kernels/Fedora/FC5/
> has this disabled by default. Give that a try ?
> 

No its still broken.
Comment 8 Julian Sikorski 2006-05-04 10:15:42 EDT
So this was caused by kernel upgrade. Good to know, hopefully the issue will be
solved soon.
Comment 9 Norman Smith 2006-05-04 10:44:50 EDT
2.6.16-1.2107_FC5 hangs for me too with anything to do with printing.  
Previous kernel OK.
  
Comment 10 Mogens Kjaer 2006-05-05 03:08:28 EDT
The problem is fixed with the 2111 kernel from:

http://people.redhat.com/davej/kernels/Fedora/FC5/RPMS.kernel/
Comment 11 Sergio Monteiro Basto 2006-05-05 08:47:32 EDT
yes, for me, 2111 fix the problem too.

btw: 
Davej on http://people.redhat.com/davej/kernels/Fedora/FC5/readme.txt
please correct from:
baseurl=http://people.redhat.com/davej/kernels/Fedora/FC$releasever/
to:
baseurl=http://people.redhat.com/davej/kernels/Fedora/FC$releasever/RPMS.kernel/
gpgcheck=0


Comment 12 Julian Sikorski 2006-05-05 11:19:24 EDT
I can confirm the fact that 2111 fixes the problem as well.

Note You need to log in before you can comment on or make changes to this bug.