Bug 190587 - 2.6.16-1.2107 issues with squid and getting email
2.6.16-1.2107 issues with squid and getting email
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2006-05-03 15:22 EDT by Vassilios Kotoulas
Modified: 2015-01-04 17:26 EST (History)
6 users (show)

See Also:
Fixed In Version: kernel-2.6.16-1.2111_FC5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-05-06 11:50:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Vassilios Kotoulas 2006-05-03 15:22:02 EDT
Description of problem:

after kernel update the internet performance using squid is very bad. Pictures
don't load, sometimes text don't load either. When I configure any browser to
connect directly to the internet the performance is good. Same performance
problem with getting email with evolution+spamassasin.
I am using ppp and a dsl modem to connect to the internet.

Version-Release number of selected component (if applicable):

How reproducible:
allways. when I boot kernel-2.6.16-1.2096_FC5 everything is OK

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
Comment 1 Vassilios Kotoulas 2006-05-03 16:34:26 EDT
update: When I uncheck external tests from the spam section in evolotion,
recieving email is fast. There was no problem with external tests with
Comment 2 Andreas M. Kirchwitz 2006-05-03 18:01:41 EDT
The problem with Squid is related to the object size.
Smaller objects (max. 1-2 kB) are okay, but larger objects won't work
(like images or web pages > 20 kB).

Objects are loaded successfully into the cache (this can be verified
with ethereal and by looking into /var/spool/squid), but the objects
are not correctly sent to the calling application. It's not the fault
of the web browser, because "telnet localhost 3128" shows the problem
as well.

With the previous kernel 2.6.16-1.2096_FC5, everything is fine.
"sysctl -a" shows no significant differences of kernel settings.
There might be more applications affected by this, but Squid is
a very obvious one and easy to reproduce.

Don't know if this is a problem in the kernel, or in certain
applications (like Squid) that is just triggered by the kernel
Comment 3 Dave Jones 2006-05-03 23:37:10 EDT
does booting with pci=nomsi make this go away?
Comment 4 Dave Jones 2006-05-04 00:14:18 EDT
Actually, that option is also broken in this kernel (sigh).

2108, available from http://people.redhat.com/davej/kernels/Fedora/FC5/
has this disabled by default. Give that a try ?
Comment 5 Vassilios Kotoulas 2006-05-04 16:08:38 EDT
it doesn't work with 2108 either
Comment 6 Martin Donald 2006-05-04 17:51:14 EDT
With this kernel 2.6.16-1.2107 fetchmail cannot fetch my mail. I returned to
kernel 2.6.16-1.2096 and I could then get my mail as usual.
Comment 7 Graydon Saunders 2006-05-04 20:30:14 EDT
Same experience as Martin Dnald; fetchmail to exim to procmail/spamassassin 
mail chain, working for years, gets through the first email download (pop3 
protocol) and hangs on 

2006-05-03 21:25:50 SMTP data timeout (message abandoned) on connection from
+localhost (grithr.localdomain)

Reverting to 2096 and the problem goes away.  Didn't get anything in the exim 
logs, mail log, procmail log, or /var/log/messages.
Comment 8 Christian Weiss 2006-05-06 04:52:10 EDT
Same here, but for me kernel-2.6.16-1.2111_FC5 fixed the problem.
Comment 9 Vassilios Kotoulas 2006-05-06 11:50:12 EDT
yes, kernel-2.6.16-1.2111_FC5 fixed it
Comment 10 Trevor Cordes 2006-07-13 23:47:03 EDT
I'm seeing this exact same problem with squid and 2.6.17-1.2139_FC5smp.  Some
objects it loads fine and fast, others take forever or come up broken.  Doesn't
matter if I browse from firefox/linux or IE/windows.  If I turn off proxy use in
the browser, browsing is very fast.

I thought it was my upstream proxy server having a cow, but I changed squid to
always use DIRECT and the problem remains.

The problem started the very first day I installed FC5.  My setup ran perfectly
fine under FC3 right before that.

Any ideas?
Comment 11 Andreas M. Kirchwitz 2006-07-14 05:56:11 EDT
Have you tried putting "net.ipv4.tcp_window_scaling = 0"
in "/etc/sysctl.conf" (reboot required) or running
"sysctl -w net.ipv4.tcp_window_scaling=0" (not for existing
TCP connections, only for new ones from now on)?
Just a wild guess, and not related to the original problem
of this ticket. ;-)
Comment 12 Trevor Cordes 2006-08-01 04:12:37 EDT
I retract comment #10.  The problem I was having seemed to be a multi-day but
transient internet connectivity issue where much of the net was dropping
packets.  I was mistaken into thinking it was squid because one site I used to
browse through squid now refuses to work through squid (europac.net).  DIRECT
works fine, through squid (with IE, FF, etc) it fails.  Weird!  But obviously
some other sort of bug.  (And that site works fine with my other network that
uses FC3 squid!)  Please don't keep this bug open on my account.

Note You need to log in before you can comment on or make changes to this bug.