Bug 190605 - rpm claims to be version 9.5 but is version 8.8.5
rpm claims to be version 9.5 but is version 8.8.5
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: amaya (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Aurelien Bompard
Fedora Extras Quality Assurance
:
: 192590 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-03 16:51 EDT by Georg Lutz
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-08 06:21:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Georg Lutz 2006-05-03 16:51:14 EDT
Description of problem:

As time of writing (2005-05-03) the amaya rpm in the extras repository of FC5
has the version number 9.5:

---
gal@ercws055:~$ rpm -qi amaya
Name        : amaya                        Relocations: (not relocatable)
Version     : 9.5                               Vendor: Fedora Project
Release     : 1.fc5                         Build Date: Mo 01 Mai 2006 10:54:44 CEST
Install Date: Mi 03 Mai 2006 15:33:44 CEST      Build Host:
hammer2.fedora.redhat.com
Group       : Applications/Internet         Source RPM: amaya-9.5-1.fc5.src.rpm
Size        : 17701697                         License: W3C Software License
Signature   : DSA/SHA1, Mo 01 Mai 2006 12:34:54 CEST, Key ID 82ed95041ac70ce6
Packager    : Fedora Project <http://bugzilla.redhat.com/bugzilla>
URL         : http://www.w3.org/Amaya
Summary     : W3C's browser/web authoring tool
Description :
Amaya is a WYSIWYG browser/web authoring tool from the W3C.

This graphical HTML Editor supports many of the latest
draft standards for HTML/XHTML.
---


But the binary is in fact version 8.8.5 (start amaya - help menu - about amaya).
Comment 1 Aurelien Bompard 2006-05-08 06:21:35 EDT
The tarball is the 9.5 version from amaya's website, that is certain. The help
menu is wrong here.
Comment 2 Georg Lutz 2006-05-08 14:34:22 EDT
(In reply to comment #1)
> The tarball is the 9.5 version from amaya's website, that is certain. The help
> menu is wrong here.

OK, I think I know what happened here, the help menu isn't wrong...

For some strange reasons - which I can't follow - the amaya team decided to
support two different version (8 and 9) and to put them in one tarball named
after version 9.

The version 9 has an advanced user interface which makes use of wx. Version 8
makes use of gtk or gl. 

I just looked into the tarball of the fedora source rpm and found that there is
already a spec file for all three version (gtk, gl, wx). For gtk and gl the
version number is 8.8.5, for wx 9.5 .

The spec file which comes with the fedora source rpm has a version number of 9.5
but builts in fact version 8.8.5 (gtk version to be precise).

So either the version number of the rpm should be changed to 8.8.5 or the spec
file to really build version 9.5 . Personally I would appreciate version 9 (wx),
because the interface is nicer and clearer. ;-)
Comment 3 Aurelien Bompard 2006-05-08 15:25:07 EDT
OK, thanks for looking at this.
This package is orphaned since sept 2005, so if you're interested in Amaya and
want to take it over, follow the procedure to become an Extras Contributor,
submitting your new version of the package. I'll review it.
Otherwise, this package is pretty much dead, and may be removed in future
versions of Fedora.
Comment 4 Aurelien Bompard 2006-05-21 10:01:27 EDT
*** Bug 192590 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.