Bug 190649 - Networking fails after upgrading to kernel- 2.6.16-1.2107
Networking fails after upgrading to kernel- 2.6.16-1.2107
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-04 04:01 EDT by Kam Leo
Modified: 2015-01-04 17:27 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-06 19:58:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kam Leo 2006-05-04 04:01:59 EDT
Description of problem:

FC5 is running as a VMware Workstation 5.5.1 guest OS. Network interface eth0
cannot be activiated following upgrade of kernel to 2.6.16-1.2107. Fails to
obtain IP address using DHCP. 

No problem obtaining IP address using previous kernel 2.6.16-1.2096.

Version-Release number of selected component (if applicable):

2.6.16-1.2107

How reproducible:

Every time.

Steps to Reproduce:
1. Start VMware Workstation 5.5.1 on Windows 2000 Pro host OS
2. Start FC5 x86_64 guest OS
3. Select "Fedora Core (2.6.16-1.2096_FC5)" from Grub menu
4. Log in as superuser
5. Use yum and upgrade kernel and kernel-devel
6. Restart system
7. Select "Fedora Core (2.6.16-1.2107_FC5) from Grub menu


Actual results:

Get this displayed on terminal

Bring up interface eth0:
Determining IP information for eth0... failed
                                       [FAILED]
Expected results:

Interface eth0 successfully brought up.
[OK] in place of [FAILED].

Additional info:

Do not have this problem on the 32-bit FC5 guest OS after upgrading the kernel
to 2.6.16-1.2107.
Comment 1 Jörgen Jonsson 2006-05-04 06:54:40 EDT
I do have this problem on the 32-bit FC5 guest OS after upgrading the kernel
to 2.6.16-1.2107.
Comment 2 Niall Hallett 2006-05-04 12:30:32 EDT
I also have this problem on all three of my network interfaces with this kernel
on an x86_64 system. Had to revert to 2.6.16-1.2096.
Comment 3 tengel 2006-05-04 14:15:32 EDT
Also happens here - Dell Precision 450 (32bit) using e1000 module, vanilla
install. 2.6.16-1.2096 works as expected. A basic ping test seems to work, but
any higher-level usage results in a stalled connection.

Comment 4 Hin-Tak Leung 2006-05-05 09:53:02 EDT
failed for me as well - had to revert to 2.6.16-1.2096 from 2.6.16-1.2107.
x86_64 - 

under kernel 2.6.16-1.2096
dmesg |grep 'eth'
forcedeth.c: Reverse Engineered nForce ethernet driver. Version 0.49.
eth0: forcedeth.c: subsystem: 0105b:0ca2 bound to 0000:00:0a.0
Comment 5 Dave Jones 2006-05-06 19:58:24 EDT

*** This bug has been marked as a duplicate of 2111 ***

Note You need to log in before you can comment on or make changes to this bug.