Bug 190653 - The application crashes on startup
Summary: The application crashes on startup
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: yumex   
(Show other bugs)
Version: 4
Hardware: i386
OS: Linux
medium
urgent
Target Milestone: ---
Assignee: Tim Lauridsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 190801 190906 191104 191408 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-05-04 09:21 UTC by Arjen Dijkstra
Modified: 2007-11-30 22:11 UTC (History)
7 users (show)

Fixed In Version: 1.0.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-14 08:09:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Traceback (732 bytes, text/plain)
2006-05-04 09:21 UTC, Arjen Dijkstra
no flags Details
yum.conf (135 bytes, text/plain)
2006-05-08 07:07 UTC, Nick Thompson
no flags Details
yum.con (149 bytes, application/octet-stream)
2006-05-08 07:12 UTC, Arjen Dijkstra
no flags Details

Description Arjen Dijkstra 2006-05-04 09:21:40 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Arjen Dijkstra 2006-05-04 09:21:40 UTC
Created attachment 128591 [details]
Traceback

Comment 2 Tim Lauridsen 2006-05-05 07:06:24 UTC
I will investigate this issue.

Comment 3 Tim Lauridsen 2006-05-05 11:04:01 UTC
*** Bug 190801 has been marked as a duplicate of this bug. ***

Comment 4 Tim Lauridsen 2006-05-08 06:54:28 UTC
*** Bug 190906 has been marked as a duplicate of this bug. ***

Comment 5 Tim Lauridsen 2006-05-08 06:57:21 UTC
Please add your yum.conf's to this bugzilla.
And tell me if you have done any modifications

Comment 6 Nick Thompson 2006-05-08 07:07:14 UTC
Created attachment 128728 [details]
yum.conf

Comment 7 Arjen Dijkstra 2006-05-08 07:12:46 UTC
Created attachment 128729 [details]
yum.con

I haven't done any modifications

Comment 8 Tim Lauridsen 2006-05-09 09:36:05 UTC
*** Bug 191104 has been marked as a duplicate of this bug. ***

Comment 9 Dawid Zamirski 2006-05-09 16:16:39 UTC
Ok, I found the root of the problem. In yum.conf there is obsoletes flag which
in my config is set to 1 by default. If I set it to 0 I can reporoduce the bug.
I have comited a patch to Yumex 1.0.X branch in SVN

Comment 10 John Williams 2006-05-10 04:13:40 UTC
This fixes the problem for me too (I reported bug #190801), but now I get
several versions of the same module appearing on my updates list.  Is this as it
should be?  Also, when I update one of the duplicated modules, it still appears
on the updates list after yumex has "refreshed" itself (reloaded its lists).  At
least it no longer crashes ;-)

Comment 11 Tim Lauridsen 2006-05-10 08:08:36 UTC
(In reply to comment #9)
> Ok, I found the root of the problem. In yum.conf there is obsoletes flag which
> in my config is set to 1 by default. If I set it to 0 I can reporoduce the bug.
> I have comited a patch to Yumex 1.0.X branch in SVN

Nice Dawid,
I have made yumex 1.0.1 release with your fixes.



Comment 12 Tim Lauridsen 2006-05-12 10:17:29 UTC
*** Bug 191408 has been marked as a duplicate of this bug. ***

Comment 13 Tim Lauridsen 2006-05-12 11:46:53 UTC
Yumex 1.0.1 has now hit the mirrors, so try updating and let me know if it fixes
this error.

Comment 14 Tero Keski-Valkama 2006-05-12 13:28:55 UTC
It is fixed for me. Thanks!

Comment 15 Nick Thompson 2006-05-13 10:27:31 UTC
Looks good here as well - many thanks for your time and effort


Note You need to log in before you can comment on or make changes to this bug.