Bug 190673 - FC5 flex version looks quite old
FC5 flex version looks quite old
Status: CLOSED DUPLICATE of bug 160658
Product: Fedora
Classification: Fedora
Component: flex (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Petr Machata
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-04 08:57 EDT by Benjamin Thery
Modified: 2015-05-04 21:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-30 06:13:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Benjamin Thery 2006-05-04 08:57:51 EDT
Description of problem:

This is not really a bug report but more an update request.
On FC5, I'm not able to compile the latest snapshots of MIPL (Mobility for IPv6)
because they introduced in their lex file some directives that are not 
supported by the version of flex shipped in FC5: 2.5.4a (released in 1997).
Those options are '%top{' and options 'noyyget_*'
They are supported by flex 2.5.31 and above.

After some googling I discovered that the flex state seems ambiguous as many 
distributions ship different versions of flex.

Is there any plan to update the flex version shipped in fedora?


Version-Release number of selected component (if applicable):

2.5.4a

How reproducible:

Always.

Steps to Reproduce:
1. Download latest snapshot of MIPL from
2. autoreconf -i
3. ./configure (with the proper options)
4. make
5. flex   scan.l
"scan.l", line 28: unrecognized '%' directive
...
"scan.l", line 48: unrecognized %option: yyget
"scan.l", line 49: unrecognized %option: yyget
...
 
Actual results:

make fails.

Error is:

The following directives are not supported by flex 2.5.4a:

%top{
%option noyyget_lineno noyyset_lineno
%option noyyget_in noyyset_in
%option noyyget_out noyyset_out
%option noyyget_debug noyyset_debug
%option noyyget_leng
%option noyyget_text

Expected results:

make succeeds

Additional info:
Comment 1 Petr Machata 2006-05-10 04:57:19 EDT
New flex was one of things I wanted to push when I took over the maintenance of
flex.  But for the same reasons that are mentioned here [1] I didn't.  I'll see
if we can provide new flex as extras package, or something along these lines, so
those more adventurous can see if it works. (The problem obviously is that flex
is required for building, so mere installation doesn't show anything. You need
to actually use it to build things, and vastly less people build with flex on
fedora than just use it...)

[1] https://www.redhat.com/archives/fedora-devel-list/2006-May/msg00077.html
Comment 2 Petr Machata 2006-06-30 06:13:08 EDT

*** This bug has been marked as a duplicate of 160658 ***

Note You need to log in before you can comment on or make changes to this bug.