Bug 190680 - 256MiB RAM is not enough for installing xen guest via VNC
256MiB RAM is not enough for installing xen guest via VNC
Status: CLOSED RAWHIDE
Product: Fedora Documentation
Classification: Fedora
Component: release-notes (Show other bugs)
devel
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Release Notes Tracker
Karsten Wade
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-04 10:01 EDT by Robin Green
Modified: 2007-04-18 13:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-10 12:20:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robin Green 2006-05-04 10:01:58 EDT
Description of problem:
Installer crash when installing a xen guest - no meaningful error message provided.

Version-Release number of selected component (if applicable):
FC5 installer

How reproducible:
Haven't tried

Steps to Reproduce:
1. /usr/sbin/xenguest-install.py
2. Answer the questions
3. Do the install, via VNC; select some optional packages
  
Actual results:
After saying "Press Next to start the installation", it went to the next screen
and then 1 second later, the VNC session spontaneously shut down. On the xen
guest console there was only this:

install exited abnormally
sending termination signals...done
sending kill signals...done
disabling swap...
unmounting filesystems...
        /mnt/runtime done
        disabling /dev/loop0
        /proc done
        /dev/pts done
        /sys done
        /tmp/ramfs done
        /selinux done
you may safely reboot your system

Expected results:
No crash - or at least a more helpful error message
Comment 1 Jeremy Katz 2006-05-04 17:25:16 EDT
What are you running on the host?  Is this fully reproducible (I haven't seen it...)
Comment 2 Robin Green 2006-05-05 08:37:19 EDT
(In reply to comment #1)
> What are you running on the host?

Just gnome-terminal, mplayer and the usual services.

>  Is this fully reproducible (I haven't seen it...)

Yes. I tried running gdbserver on the guest and it failed due to bug 190810. So
I tried directly attaching to the larger anaconda process (there were 2) with
gdb on the guest and upped the RAM allocation from 256MB to 300MB (to make some
space for gdb), and got this:

(gdb) cont
Continuing.
Detaching after fork from child process 266.
Detaching after fork from child process 267.
Detaching after fork from child process 268.
Detaching after fork from child process 269.
Detaching after fork from child process 270.
Detaching after fork from child process 271.
Detaching after fork from child process 304.
Detaching after fork from child process 305.
Detaching after fork from child process 306.
Detaching after fork from child process 307.
Detaching after fork from child process 308.
Detaching after fork from child process 309.

Program terminated with signal SIGKILL, Killed.
The program no longer exists.
(gdb) install exited abnormally
Terminated
sh-3.1# sending termination signals...done
sending kill signals...done
disabling swap...
unmounting filesystems...
        /mnt/runtime done
        disabling /dev/loop0
        /proc done
        /dev/pts done
        /sys done
        /tmp/ramfs done
        /selinux done
you may safely reboot your system

Maybe it's getting killed by the OOM killer? Maybe 256MB is not enough for an
x86_64 install?
Comment 3 Robin Green 2006-05-10 08:39:41 EDT
(In reply to comment #2)
> Maybe it's getting killed by the OOM killer? Maybe 256MB is not enough for an
> x86_64 install?

I was right. 256MiB, which is what I tried before, is not enough memory for an
x86_64 install (at least for a VNC install on Xen). I added another memory
module and retried, giving 512MiB to the xenU domain this time, and this time
the install completed successfully.

Reassigning to Fedora Documentation, because this is a bug in the release notes,
which say:

"Minimum RAM for graphical: 256MiB"
Comment 4 Karsten Wade 2006-05-10 09:11:02 EDT
There is a new section in the FC5 errata release notes that says:

"At least 256 MiB of RAM for each guest, plus at least 256 MiB ram for the host"

The directions you are referring to are for a standard installation, and the
minimum rules must not be applied to Xen.

Because I have to push up some other changes anyway, I'm adding a note in the
Virtualization section to increase memory for the guest if you receive out of
memory errors or as a troubleshooting step.

Comment 5 Robin Green 2006-05-10 09:44:17 EDT
I think it's impossible for an install to work with only 256MiB. The filesystem
creation process uses tons of memory, for some reason.
Comment 6 Karsten Wade 2006-05-10 09:59:25 EDT
I wasn't clear from what you said above; are you saying you had a total of 256
MiB in the entire system, or 256 MiB designated for the Xen guest?

If the system total was 256, then I agree that it wasn't enough, and
fortunately, so does the release notes:

http://fedora.redhat.com/docs/release-notes/fc5/#id2885418

That is the line I updated, which should be live in about 10 minutes, to say
that you may need more RAM if you get OOM errors or otherwise are
troubleshooting a problematic installation.

If you are saying that you did follow those guidelines and had 256 each for the
host and guest ... then we need input from a Xen hacker about these values, if
they should be bumped, etc.

Thanks.
Comment 7 Mohammed Ghanawi 2006-10-10 14:47:40 EDT
I had the same issue when assigning 256Mb to a guest during installation
(through virt-manager), until I used 512Mb the installation went through without
crashing. This seems to happen all the time.

I also had problems installing a fully virtualized guest, I cannot seem to get
passed the initial setup, the system crashes when it detects the local hard drive.
Comment 8 Karsten Wade 2007-02-10 12:20:50 EST
The release notes now link out to a release-specific guide to using Xen:

http://fedoraproject.org/wiki/FedoraXenQuickstartFC6

When so many details are needed, it becomes time to move the content from the
release notes and into a stand-alone document.

Thanks for the report. :)

Note You need to log in before you can comment on or make changes to this bug.