Bug 19070 - compiling ip_masq fails sometimes
Summary: compiling ip_masq fails sometimes
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
: 18706 20169 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-13 18:37 UTC by Alexander Kourakos
Modified: 2007-04-18 16:29 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-15 02:32:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alexander Kourakos 2000-10-13 18:37:39 UTC
If the kernel is compiled with
CONFIG_IP_MASQUERADE and without 
CONFIG_IP_MASQUERADE_MOD, it will fail with errors referring to 
'ip_masq_hash' and 'ip_masq_unhash'.

The fix I used is either to configure for both MASQUERADE and 
MASQUERADE_MOD, or add these lines near the end of 
<linux/ip_masq.h>:

extern int ip_masq_hash(struct ip_masq *);
extern int ip_masq_unhash(struct ip_masq *);

I believe that this is the same bug as #18706

Comment 1 Alexander Kourakos 2000-10-13 18:54:26 UTC
why does Bugzilla say "Red Hat Linux - 7.07.0"?

Comment 2 Bill Nottingham 2000-11-04 07:42:30 UTC
*** Bug 18706 has been marked as a duplicate of this bug. ***

Comment 3 Bill Nottingham 2000-11-04 07:46:45 UTC
*** Bug 20169 has been marked as a duplicate of this bug. ***

Comment 4 Need Real Name 2000-11-21 22:59:07 UTC
Tryed the first solution (both MASQUERADE and MASQUERADE_MOD) did not work...


Comment 5 Need Real Name 2000-11-22 23:47:21 UTC
Ok! Got it right this time. The solution with CONFIG_MASQUERADE=y and 
CONFIG_MASQUERADE_MOD=y does work!
Note that to have CONFIG_MASQUERADE_MOD available you must enable experimental 
modules...

Comment 6 Hans Deragon 2001-04-15 20:00:44 UTC
Someone else suggested another solution in google's usenet search site.  Here
is the text:

------>
From: aix_steve@my-deja.com (aix_steve@my-deja.com)
 Subject: Re: make[3]: *** [ip_masq.o] Error 1 
 Newsgroups: comp.os.linux.development.system
 Date: 2000-12-22 13:20:07 PST 

The problem is that the two symbols are defined in ip_masq_mod.h
which is only included if you make IP_MASQUERADING as a module.
Edit the file ./net/ipv4/ip_masq.c and add two lines:

int ip_masq_hash(struct ip_masq *ms);
int ip_masq_unhash(struct ip_masq *ms);

Put these after the #includes but before the EXPORT_SYMBOLs

After I did this, the kernel built and ran fine.

-- Steve
<------

Reference:

http://groups.google.com/groups?hl=en&lr=&safe=off&ic=1&th=e425277b6ec84a63&seekd=964242614#964242614


Note You need to log in before you can comment on or make changes to this bug.