Bug 19072 - can't modularize SCSI driver
Summary: can't modularize SCSI driver
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
: 22370 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-13 18:43 UTC by Alexander Kourakos
Modified: 2007-04-18 16:29 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-15 02:33:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alexander Kourakos 2000-10-13 18:43:19 UTC
I can't load the SCSI driver as a module, because drivers/scsi/scsi.h 
references 'req_finished_io' and this function is not exported by 
driver/block/ll_rw_blk.c where it is defined.

Comment 1 Alan Cox 2000-10-14 21:51:56 UTC
Known problem. You can add an EXPORT_SYMBOL(req_finished_io) to the end of this
file and
rebuild from make dep and it will fix the problem.


Comment 2 Bill Nottingham 2000-12-18 15:33:09 UTC
*** Bug 22370 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.