Bug 190748 - 3.5.2-0.3.fc5 lost the capacity to automatically mount external USB drives
3.5.2-0.3.fc5 lost the capacity to automatically mount external USB drives
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-04 17:04 EDT by Joe Christy
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-20 09:03:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Christy 2006-05-04 17:04:55 EDT
Description of problem:
Since upgrading to kdebase-3.5.2-0.3.fc5, my two external USB drives no longer
get mounted automatically when I login to a KDE session.

Version-Release number of selected component (if applicable):
3.5.2-0.3.fc5

How reproducible:
always

Steps to Reproduce:
1. upgrade to kdebase-3.5.2-0.3.fc5
2. reboot system with external USB drives attached.
3. log in, using a KDE session
  
Actual results:
raw devices /dev/sd[whatever] & partitions /dev/sd[whatever][n] get created, but
no mount points appear in /media and devices don't get mounted.

Expected results:
devices /dev/sd[whatever] & /dev/sd[whatever][n] get created, mount points
[their-disklable]s appear in /media and devices gets mounted there.


Additional info:
This used to work acceptabley well, pre-upgrade. Now dmesg shows the kernel
scanning the USB bus and udev creates the nodes in /dev/, but that's it.

Moreover, I can't figure out a work-around to mount the disks at some persistent 
location automatically.

In order to mount the disks, I have to pore over dmesg to figure out which disk
is which, and then create mount points outside of /media and mount them by hand.
If I create mount points in /media (the desired location, see below) by hand,
then KDE somehow wakes up and creates new mount points /media/[disklable]-1
beside the hand created /media/disklable]s and mount gets confused.

Since the disks are used for backing up the several linux/*BSD/widows/OSX
machines on my network and all the various backup scripts/software rely on
knowing that the appropriate disc is mounted at /media/backup[x] acording to the
OS type, my backups break.

Logging in with a [extremely distasteful, intelligence-insulting] gnome session
does create the mount points and mount the devices as expected.

Of course what would be *ideal* is if attached USB disks would get mounted at
boot time, without anyone having to log in to the console. This was possible
with FC4, but gnome-volume-manager "improved" it out of existence.

Unfortunately, I am not clever enough to glean from the udev documentation how
to write rules to do this. The complication is that I have multiple USB disks
attached, and as I understand it, which physical device gets assigned which
device name by the kernel is non-deterministic.
Comment 1 Ngo Than 2006-05-05 13:30:58 EDT
Could you please try new kdebase-3.5.2-0.4.fc5 from FC5-update? and probably  
try with new user.

It looks strange to me because i cannot reproduce this problem with 
kdebase-3.5.2-0.3.fc5 on several test machines here.
Comment 2 Joe Christy 2006-05-05 17:15:59 EDT
I see the same behavior with kdebase-3.5.2-0.4.fc5, and my usual user account. I
have a long compile going now, and will check with a new account when I get a
chance.
Comment 3 Ngo Than 2006-05-06 05:54:03 EDT
Could you please check if "KDED Media Manager Service" is running on your 
machine? You find it in kcontrol->KDE Componetns->Service Manager

Please make sure that you have to unplug the USB drives before changing this.

Are you sure that this problem does not appear with kdebase-3.5.2-0.2.fc5?
Comment 4 Joe Christy 2006-05-06 12:57:34 EDT
OK, I did some experimenting and figured it out. Before I explain, let me
respond to comment #3
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=190748#c3:
Yes, "KDED Media Manager Service" is running and yes, I'm sure that it did not
appear with kdebase-3.5.2-0.2.fc5.

Unlike the prior behavior of KDE and the current behavior of Gnome, USB drives
that are attached at boot time do not have an entry created in /media at login
time. Furthermore, unlike the prior behavior of KDE, USB drives that are
attached at boot time don't get mounted automatically at login time. Nor do they
pop up a window asking the user what they want to do, unlike the case when a USB
drive is attached post login.

My KDE desktop is set not to display icons, since I'm a dinosaur who's been
using Unix everday since the mid-70's who agrees with Ken Thompson when he said
"Graphical User Interfaces make easy things trivial and difficult things
impossible." Therefore, I initially missed the unmounted removable disk icons
which would have provided a clue, and by the time I thought to turn those icons
on, I had already created /media/[disklable] mount points by hand, so the
desktop icons KDE produced were labled [disklable]-1, and as I remarked above,
clicking them confused mount.

When I have unmounted removable drive icons turned on in my KDE desktop, I do
indeed see the unmounted (by new, post-3.5.2-0.2.fc5 default) USB discs that
were attached at boot time. While, unlike the case of freshly attached USB
discs, I don't get a dialog asking me if I want to open them in a new window,
thereby mounting them, I can at least click them to mount.

Needless to say, the change to requiring unprompted graphical user interaction
to mount USB discs that are present at boot time is unacceptable in my use case
- using USB discs for automatic network backups. Fortunately, a couple of hours
of renewed poring over the udev docs and a tedious modify udev rules/fstab,
reboot, repeat cycle did finally uncover a method to have my backup discs
mounted not-quite-at* boot-time.

So, the bottom line is the bug is either a user headspace error or a fresh
KDE/gnome-volume-manager mis-feature, depending on your point of view. If you
agree with me that it is the latter, the bug can be changed to an RFE to address
my use case by restoring the pre-kdebase-3.5.2-0.3.fc5 (or even pre-FC5)
behavior. Otherwise you can just close it.

(*) For some reason, the system hasn't finished probing my USB buses so my udev
rule hasn't been invoked and the corresponding devices that I mount in fstab
don't exist by the time in the init sequence that filesystems are getting mount,
so I get an error from rc.sysinit. However, the mount default is to retry the
mounts, so they have been mounted by the time I can check for the discs being
mounted.

Note You need to log in before you can comment on or make changes to this bug.