Bug 190749 - mc causes immediate segfault of urxvt
mc causes immediate segfault of urxvt
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rxvt-unicode (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-04 17:18 EDT by marco atzeri
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-05 06:15:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description marco atzeri 2006-05-04 17:18:35 EDT
Description of problem:
mc causes immediate segfault of urxvt

Version-Release number of selected component (if applicable):
rxvt-unicode-7.7-1.fc5
mc-4.6.1a-12.FC5

How reproducible:
executing mc under urxvt

Steps to Reproduce:
1. executing urxvt
2. executing mc in urxvt 
3.

log of multiple tentative from /var/log/message
May  4 22:43:43 enterprise kernel: urxvt[18299]: segfault at 0000000000000000
rip 00000039e3a1ec60 rsp 00007fffffe7e880 error 4
May  4 22:43:54 enterprise kernel: urxvt[18352]: segfault at 0000000000000000
rip 00000039e3a1ec60 rsp 00007ffffff66440 error 4
May  4 22:46:07 enterprise kernel: urxvt[18429]: segfault at 0000000000000000
rip 00000039e3a1ec60 rsp 00007ffffffec8b0 error 4
May  4 22:47:50 enterprise kernel: urxvt[18336]: segfault at 0000000000000000
rip 00000039e3a1ec60 rsp 00007fffffb033b0 error 4
May  4 22:47:59 enterprise kernel: urxvt[18555]: segfault at 0000000000000000
rip 00000039e3a1ec60 rsp 00007fffff946f00 error 4
May  4 22:50:10 enterprise kernel: urxvt[18646]: segfault at 0000000000000000
rip 00000039e3a1ec60 rsp 00007fffffd4fef0 error 4

Actual results:
immediate crash of urxvt

Expected results:
mc execution in urxvt terminal

Additional info:
mc is correctly working in xterm and in console
mc is working under rxvt. the layout is orrible likely due to font representaion
but no crashes
Comment 1 Frank Schmitt 2006-05-10 03:16:59 EDT
rxvt crashes in UTF-8 locals as soon as you send some ISO-8859-15 chars to
console. It seems to be a fontconfig issue as it segfaults in fontconfig
libraries. However it only happens with urxvt for me.
Comment 2 Andreas Bierfert 2006-05-16 18:06:10 EDT
I will see if I can contact upstream about this.
Comment 3 marco atzeri 2006-06-03 06:47:46 EDT
the urxvt crash is disapperead.
Some of the packets update seem to have solved the issue.

possible candidates between the one needed by urxvt
ldd /usr/bin/urxvt:

glibc-2.4-8         Wed 17 May 2006 07:35:37 PM CEST
libgcc-4.1.1-1.fc5  Thu 01 Jun 2006 07:32:59 PM CEST
Comment 4 Andreas Bierfert 2006-06-05 06:15:44 EDT
Thats good :) I will close this as notabug then. Please reopen if it appears again.
Comment 5 Dr. Tilmann Bubeck 2006-07-19 15:01:05 EDT
I have an up-to-date FC5 (yum update .. done) but a crash with urxvt when 
starting "/usr/sbin/ntsysv" as root. I'm using LANG=en_US.UTF-8. There is no 
problem under konsole or xterm. There is also no problem when I set LANG=C 
before executing urxvt.

Here is the stack trace:

(gdb) bt
#0  0x4c166e26 in FcFontSetSortDestroy () from /usr/lib/libfontconfig.so.1
#1  0x4c167abf in FcFontSetMatch () from /usr/lib/libfontconfig.so.1
#2  0x4c168476 in FcFontMatch () from /usr/lib/libfontconfig.so.1
#3  0x42e00110 in XftFontMatch () from /usr/lib/libXft.so.2
#4  0x08062edd in rxvt_font_xft::load ()
#5  0x080629f3 in rxvt_fontset::realize_font ()
#6  0x0806520c in rxvt_fontset::find_font ()
#7  0x0807557c in rxvt_term::scr_add_lines ()
#8  0x08061700 in rxvt_term::cmd_parse ()
#9  0x08061b04 in rxvt_term::pty_cb ()
#10 0x0808030b in io_manager::loop ()
#11 0x0805b4d9 in main ()

and here is the RPM info:

Name        : rxvt-unicode                 Relocations: (not relocatable)
Version     : 7.8                               Vendor: Fedora Project
Release     : 1.fc5                         Build Date: Tue 18 Jul 2006 
11:43:37 AM CEST
Install Date: Wed 19 Jul 2006 09:26:28 PM CEST      Build Host: 
hammer2.fedora.redhat.com
Group       : User Interface/X              Source RPM: 
rxvt-unicode-7.8-1.fc5.src.rpm
Size        : 2877787                          License: GPL
Signature   : DSA/SHA1, Wed 19 Jul 2006 10:37:28 AM CEST, Key ID 
82ed95041ac70ce6
Packager    : Fedora Project <http://bugzilla.redhat.com/bugzilla>
URL         : http://software.schmorp.de/
Summary     : Rxvt-unicode is an unicode version of rxvt
Description :
rxvt-unicode is a clone of the well known terminal emulator rxvt, modified to
store text in Unicode (either UCS-2 or UCS-4) and to use locale-correct input
and output. It also supports mixing multiple fonts at the same time, including
Xft fonts.

Note You need to log in before you can comment on or make changes to this bug.