Bug 19077 - PHP 4.0.[23](pl1)? not building
Summary: PHP 4.0.[23](pl1)? not building
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: php (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-13 19:19 UTC by Ignacio Vazquez-Abrams
Modified: 2007-04-18 16:29 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-24 22:24:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ignacio Vazquez-Abrams 2000-10-13 19:19:09 UTC
If configure is run on PHP 4.0.[23] with the option --with-gettext, the
configure script fails after not finding bindtextdomain in '-lc'.

Comment 1 Ignacio Vazquez-Abrams 2000-10-16 04:36:08 UTC
Never mind. It was a problem with finding libdb. I just took off --with-db2 and
--with-db3 and configure succeeded. Build, however, didn't...

Comment 2 Ignacio Vazquez-Abrams 2000-10-23 18:21:20 UTC
Hmm... after a bit more poking around, I was able to determine that it wasn't
finding /usr/lib/libdb2.(a|so):

"""
configure:16669: checking for bindtextdomain in -lc
configure:16688: gcc -o conftest -O2 -m486 -fno-strength-reduce -fPIC  
-L/usr/lib conftest.c -lc  -lttf -ljpeg -lgd -l -ldb2 -lgdbm -lresolv -lm -ldl
-lcrypt -lnsl  -lresolv -L/usr/lib -ljpeg 1>&5
/usr/bin/ld: cannot find -l--library=db2
collect2: ld returned 1 exit status
configure: failed program was:
#line 16677 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char bindtextdomain();

int main() {
bindtextdomain()
; return 0; }
"""

The same error happened when I force-installed db[23]-*.rpm from 7.0 (which I
hope didn't break glibc-2.1.3, right? Right?). I then removed --with-db[23] from
the spec, and libphp4.so didn't build.

I am using --sybase-ct=/opt/sybase-11.9.2, but other than that, it's the stock
rawhide php-4.0.2-2 SRPM.

Comment 3 Nalin Dahyabhai 2000-10-23 19:41:54 UTC
Try installing db1-devel and db2-devel.  These are missing build-time
dependencies which should be added to the .spec file.

Comment 4 Ignacio Vazquez-Abrams 2000-10-23 22:09:15 UTC
Survey says...nope. 4.0.2 seems to be building now (odd...), but 4.0.3pl1 is
still a no-go on the so.

Comment 5 Nalin Dahyabhai 2000-10-24 19:48:09 UTC
I take it the 4.0.3pl1 which is not building is the errata version.  Is it
failing detecting one of the Berkeley DB libraries, or elsewhere?

Comment 6 Ignacio Vazquez-Abrams 2000-10-24 22:10:23 UTC
Actually no, it was the tarball with the spec from 4.0.2 on Rawhide. The errata
version doesn't show on the errata pages, but I'm downloading it now and we'll
see from there...

Comment 7 Ignacio Vazquez-Abrams 2000-10-24 22:24:15 UTC
Damn. Still can't find libdb2.so:

"""
configure:16753: checking for bindtextdomain in -lc
configure:16772: gcc -o conftest -O2 -m486 -fno-strength-reduce -fPIC  
-L/usr/lib conftest.c -lc  -ljpeg -l -ldb2 -lgdbm -lresolv -lm -ldl -lcrypt
-lnsl -lttf -lpng -ljpeg -lz -lresolv -L/usr/lib -ljpeg 1>&5
/usr/bin/ld: cannot find -l--library=db2
collect2: ld returned 1 exit status
configure: failed program was:
#line 16761 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char bindtextdomain();

int main() {
bindtextdomain()
; return 0; }
"""

Comment 8 Ignacio Vazquez-Abrams 2000-10-27 16:34:51 UTC
Hmm...never mind. We had to refresh some RPMs due to another problem, and now it
seems to be working fine. Just when it was getting interesting :)


Note You need to log in before you can comment on or make changes to this bug.