Bug 190802 - No -debuginfo packages available for cyrus-imapd
Summary: No -debuginfo packages available for cyrus-imapd
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: cyrus-imapd   
(Show other bugs)
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Petr Rockai
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
: 198342 (view as bug list)
Depends On:
Blocks: 176344
TreeView+ depends on / blocked
 
Reported: 2006-05-05 09:55 UTC by Bastien Nocera
Modified: 2018-10-19 20:39 UTC (History)
1 user (show)

Fixed In Version: RHBA-2007-0258
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-01 17:16:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cyrus-imapd-dont-strip.patch (2.02 KB, patch)
2006-05-05 10:29 UTC, Bastien Nocera
no flags Details | Diff
cyrus-imapd-dont-strip-spec.patch (1.20 KB, patch)
2006-05-05 10:30 UTC, Bastien Nocera
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0258 normal SHIPPED_LIVE cyrus-imapd bug fix update 2007-05-01 17:14:55 UTC

Description Bastien Nocera 2006-05-05 09:55:15 UTC
cyrus-imapd-2.2.12-3.RHEL4.1

Segmentation faults cannot be investigated easily as there's no -debuginfo
package available for cyrus-imapd, and that the binaries are stripped.

Comment 1 Bastien Nocera 2006-05-05 10:02:46 UTC
That looks like the culprit (from the .spec):
# Strip binaries
%{__strip} --strip-unneeded %{buildroot}%{_cyrexecdir}/* ||:


Comment 2 Bastien Nocera 2006-05-05 10:25:58 UTC
There's also the "-s" in the install targets:
$ grep -r INSTALL . | grep -- -s
./netnews/Makefile.in:  $(INSTALL) -s -m 755 remotepurge $(DESTDIR)$(service_path)
./imtest/Makefile.in:   $(INSTALL) -s -m 755 imtest $(DESTDIR)$(exec_prefix)/bin
./installsieve/Makefile.in:     $(INSTALL) -s -m 755 installsieve
$(DESTDIR)$(exec_prefix)/bin

And more in the spec file:
%{__install} -s -m 2755 deliver-wrapper %{buildroot}%{_cyrexecdir}/

Finally, rpm isn't too clever. If you have "%define debug_package %{nil}", even
if it's commented, it will be set.

Comment 3 Bastien Nocera 2006-05-05 10:29:21 UTC
Created attachment 128651 [details]
cyrus-imapd-dont-strip.patch

Package patch.

Comment 4 Bastien Nocera 2006-05-05 10:30:17 UTC
Created attachment 128652 [details]
cyrus-imapd-dont-strip-spec.patch

And (bit mangled) patch for the .spec file itself.

Comment 6 Bastien Nocera 2006-07-11 14:14:50 UTC
*** Bug 198342 has been marked as a duplicate of this bug. ***

Comment 8 RHEL Product and Program Management 2006-08-18 16:00:10 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 15 Red Hat Bugzilla 2007-05-01 17:16:17 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0258.html



Note You need to log in before you can comment on or make changes to this bug.