Bug 190814 - When package is named "bash", %description is incorrectly reported
When package is named "bash", %description is incorrectly reported
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: rpm (Show other bugs)
3.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-05 09:22 EDT by Binand Sethumadhavan
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-08 10:09:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
foo.spec (943 bytes, application/octet-stream)
2006-05-05 09:23 EDT, Binand Sethumadhavan
no flags Details
bash.spec (944 bytes, application/octet-stream)
2006-05-05 09:24 EDT, Binand Sethumadhavan
no flags Details

  None (edit)
Description Binand Sethumadhavan 2006-05-05 09:22:14 EDT
Attached are two specfiles, foo.spec and bash.spec. Their only difference is in
the package name:

[builder@wiggum specfile]$ diff -u foo.spec bash.spec
--- foo.spec    2006-05-05 09:24:38.000000000 -0400
+++ bash.spec   2006-05-05 09:24:04.000000000 -0400
@@ -1,5 +1,5 @@
 Version: 1.0
-Name: foo
+Name: bash
 Summary: Foo
 Release: 1
 Group: System Environment/Shells

Now, when I query each of these, I get:

[builder@wiggum specfile]$ rpm -qi --specfile foo.spec
Name        : foo                          Relocations: (not relocatable)
Version     : 1.0                               Vendor: (none)
Release     : 1                             Build Date: (not a number)
Install Date: (not installed)               Build Host: (none)
Group       : System Environment/Shells     Source RPM: (none)
Size        : (none)                           License: GPL
Signature   : (none)
Summary     : Foo
Description :
The GNU Bourne Again shell (Bash) is a shell or command language
interpreter that is compatible with the Bourne shell (sh). Bash
incorporates useful features from the Korn shell (ksh) and the C shell
(csh). Most sh scripts can be run by bash without modification. This
package (bash) contains bash version 1.0, which improves POSIX
compliance over previous versions. However, many old shell scripts
will depend upon the behavior of bash 1.14, which is included in the
bash1 package. Bash is the default shell for Red Hat Linux.  It is
popular and powerful, and you'll probably end up using it.

= = = = = = = = = = = = = W A R N I N G = = = = = = = = = = = = =

Boo!

= = = = = = = = = = = = = W A R N I N G = = = = = = = = = = = = =

[builder@wiggum specfile]$ rpm -qi --specfile bash.spec
Name        : bash                         Relocations: (not relocatable)
Version     : 1.0                               Vendor: (none)
Release     : 1                             Build Date: (not a number)
Install Date: (not installed)               Build Host: (none)
Group       : System Environment/Shells     Source RPM: (none)
Size        : (none)                           License: GPL
Signature   : (none)
Summary     : The GNU Bourne Again shell (bash).
Description :
The GNU project Bourne Again shell (bash) is a shell or command language
interpreter that is compatible with the Bourne shell (sh). Bash
incorporates useful features from the Korn shell (ksh) and the C shell
(csh) and most sh scripts can be run by bash without modification. Bash is
the default shell for Red Hat Enterprise Linux.

As you can see, when the package is named "bash", parts of the description field
vanishes.
Comment 1 Binand Sethumadhavan 2006-05-05 09:23:06 EDT
Created attachment 128655 [details]
foo.spec
Comment 2 Binand Sethumadhavan 2006-05-05 09:24:00 EDT
Created attachment 128656 [details]
bash.spec
Comment 3 Binand Sethumadhavan 2006-05-05 09:37:36 EDT
Here are the versions:

[builder@wiggum specfile]$ cat /etc/redhat-release
Red Hat Enterprise Linux ES release 3 (Taroon Update 7)
[builder@wiggum specfile]$ rpm -q redhat-release
redhat-release-3ES-13.7.3
[builder@wiggum specfile]$ rpm -q rpm
rpm-4.2.3-24_nonptl
[builder@wiggum specfile]$ sudo up2date -u

Fetching Obsoletes list for channel: rhel-i386-es-3...

Fetching Obsoletes list for channel: rhel-i386-es-3-extras...

Fetching rpm headers...

Name                                    Version        Rel
----------------------------------------------------------

All packages are currently up to date
Comment 4 Nalin Dahyabhai 2006-05-05 11:37:35 EDT
The 'rpm -qi' command is probably pulling localized versions of the summary and
description from the translation catalogs which are supplied in the 'specspo'
package.  (If you retry this with 'env LC_ALL=C rpm -qi', you'll probably get
the results the you were expecting.)
Comment 5 Binand Sethumadhavan 2006-05-08 09:07:22 EDT
Yep, that fixed it, thanks. But I still think there's a bug lurking here - it is
fine for RPM to pick up descriptions from the catalogue when I query the system
DB, but should it do the same for (a) my own spec files, (b) my own packages etc.?
Comment 6 Paul Nasrat 2006-05-08 10:09:37 EDT
A header extension such as that used for specspo is applied everywhere by design.  

Note You need to log in before you can comment on or make changes to this bug.