Bug 190818 - smartd won't start after kernel upgrade to kernel-2.6.16-1.2107_FC5
smartd won't start after kernel upgrade to kernel-2.6.16-1.2107_FC5
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-05 10:06 EDT by Hin-Tak Leung
Modified: 2015-01-04 17:27 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-05 14:14:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hin-Tak Leung 2006-05-05 10:06:24 EDT
Description of problem:

boot sequence stuck at smartd start up (after selecting interactive
start up and de-selecting eth0 initialisation - see bug 190649)

Version-Release number of selected component (if applicable):

kernel-2.6.16-1.2107_FC5

How reproducible:

always

Steps to Reproduce:
1. install kernel-2.6.16-1.2107_FC5
2. reboot
3.
  
Actual results: boot up stuck at smartd


Expected results: boot up successful


Additional info:

rpm -qf /usr/sbin/smartd
smartmontools-5.33-4.2

/sbin/lspci
...
00:06.0 IDE interface: nVidia Corporation CK804 IDE (rev a2)
00:07.0 IDE interface: nVidia Corporation CK804 Serial ATA Controller (rev a3)
00:08.0 IDE interface: nVidia Corporation CK804 Serial ATA Controller (rev a3)
...

here is the relevant disk info from dmesg (will supply more if necessary):

Probing IDE interface ide0...
Probing IDE interface ide1...
hdc: TSSTcorpCD/DVDW SH-W162C, ATAPI CD/DVD-ROM drive
ide1 at 0x170-0x177,0x376 on irq 15
Probing IDE interface ide0...
hdc: ATAPI 48X DVD-ROM DVD-R CD-R/RW drive, 2048kB Cache, UDMA(33)
Uniform CD-ROM driver Revision: 3.20
ide-floppy driver 0.99.newide

SCSI subsystem initialized
libata version 1.20 loaded.
sata_nv 0000:00:07.0: version 0.8
ACPI: PCI Interrupt Link [APSI] enabled at IRQ 23
GSI 16 sharing vector 0xB1 and IRQ 16
ACPI: PCI Interrupt 0000:00:07.0[A] -> Link [APSI] -> GSI 23 (level, low) -> IRQ 16
PCI: Setting latency timer of device 0000:00:07.0 to 64
ata1: SATA max UDMA/133 cmd 0x9F0 ctl 0xBF2 bmdma 0xCC00 irq 16
ata2: SATA max UDMA/133 cmd 0x970 ctl 0xB72 bmdma 0xCC08 irq 16
ata1: SATA link up 3.0 Gbps (SStatus 123)
ata1: dev 0 cfg 49:2f00 82:746b 83:7f01 84:4023 85:7469 86:3e01 87:4023 88:407f
ata1: dev 0 ATA-7, max UDMA/133, 156250000 sectors: LBA48
nv_sata: Primary device added
nv_sata: Primary device removed
nv_sata: Secondary device added
nv_sata: Secondary device removed
ata1: dev 0 configured for UDMA/133
scsi0 : sata_nv
input: ImPS/2 Logitech Wheel Mouse as /class/input/input1
ata2: SATA link down (SStatus 0)
scsi1 : sata_nv
  Vendor: ATA       Model: WDC WD800JD-75MS  Rev: 10.0
  Type:   Direct-Access                      ANSI SCSI revision: 05
SCSI device sda: 156250000 512-byte hdwr sectors (80000 MB)
sda: Write Protect is off
sda: Mode Sense: 00 3a 00 00
SCSI device sda: drive cache: write back
SCSI device sda: 156250000 512-byte hdwr sectors (80000 MB)
sda: Write Protect is off
sda: Mode Sense: 00 3a 00 00
SCSI device sda: drive cache: write back
 sda:<4>nv_sata: Primary device added
nv_sata: Primary device removed
nv_sata: Secondary device added
nv_sata: Secondary device removed
 sda1 sda2
sd 0:0:0:0: Attached scsi disk sda
Comment 1 Dave Jones 2006-05-05 14:14:17 EDT
2107 was horribly broken. this is very likely fixed in 2111 which just got
pushed out.

Note You need to log in before you can comment on or make changes to this bug.