Bug 19083 - Crash on reboot
Crash on reboot
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gdm (Show other bugs)
7.0
i686 Linux
high Severity high
: ---
: ---
Assigned To: Owen Taylor
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-13 16:04 EDT by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-10 14:49:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-10-13 16:04:06 EDT
From the Redhat 7 login manager,when i choose to reboot or restart the
system,after clicking OK when selecting to reboot,i get a black screen
,then i get the login manager again and then 5 or 10 seconds later,it goes
into the shut down and restart phase,but it crashes first,then it restarts
like normal.I have a Diamond Speedstar A50 Video Card.It only happens on
selection of reboot not halt or shutdown,it also happens in either KDE or
Gnome,when i select to reboot only.The message from the crash tells me to
type this in a Xterm(gdb /etc/X11/X //core where)It also tells me to submit
the bug to XFree86@XFree86.org,but i figured and was told by support to
submit it here as well...My machine is as follows(PII/400Mhz 256megs ram)
With Diamond Speedstar A50 Video Card and Creative awe64 sound card if it
even matters..Please try to help me to figure this problem out>>>When i was
running Redhat 6.2 the same problem happened and i just Downloaded Helix
Gnome from helix code web site through lynx,and selected to use their login
manager as my default login manager,and i had never seen the crash
again,but i would like to keep the Gnome from your Redhat 7 CD.


Please help!!!
Thanks JohnnyO

asap811@softhome.net
Username for support is as follows (happjo)
Comment 1 Mike A. Harris 2001-05-10 13:57:21 EDT
Sounds like it might be a gdm problem.
Comment 2 Owen Taylor 2001-07-17 18:38:19 EDT
The GDM in rawhide currently is very different from the GDM shipped
in 6.2/7.0.

This apparently had something to do with your particular setup,
and maybe your video card, since this didn't happen for most
things. (It's pretty hard for GDM to trigger a segfault
in X anyways, so there is something X related here.)

There really isn't any way I can debug this, so I'm closing this
as resolved, since I expect that changes to GDM and or X have
most likely made it go away. If you upgrade once we make a new
release incorporating a GDM-2.2 release and this still happens
please reopen this bug or file a new bug.

(You could also try installing the GNOME and GDM packages for
rawhide, but this is a pretty big set of packages, and there
are enough system changes invoveld that trying to upgrade
to it piecemeal might cause stability problems.)

Note You need to log in before you can comment on or make changes to this bug.