This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 190842 - kernel: remove explicit "Provides: kernel = %{version}" from kernel-2.6.spec
kernel: remove explicit "Provides: kernel = %{version}" from kernel-2.6.spec
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: redhat-release (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Don Domingo
Brian Brock
:
Depends On:
Blocks: 176344 211071
  Show dependency treegraph
 
Reported: 2006-05-05 12:53 EDT by David Lehman
Modified: 2010-10-22 00:55 EDT (History)
4 users (show)

See Also:
Fixed In Version: 4.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-26 19:30:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
remove incorrect explicit "provides: kernel = %{version} from kernel-2.6.spec (395 bytes, patch)
2006-05-05 12:53 EDT, David Lehman
no flags Details | Diff

  None (edit)
Description David Lehman 2006-05-05 12:53:48 EDT
Description of problem:
It has been found that even though lvm2-2.02.01-1.3.RHEL4 requires "kernel >=
2.6.9-24", it can be installed cleanly when only kernel-2.6.9-11.EL is present.

kernel-26.spec explicitly provides "kernel = %{version}". This is not only
unnecessary, but also prevents other packages from requiring a specific kernel
release. From the rpm documentation on dependencies:

    Unspecified epoch and releases are assumed to be zero, and are
    interpreted as "providing all" or "requiring any" value.

So, by explicitly providing "kernel = 2.6.9" in kernel-2.6.9-1, you satisfy any
dependency on, eg: "kernel >= 2.6.9-999". This is clearly bad. 

All packages automatically provide 

    "%{name} = %{epoch}:%{version}-%{release}"

In the case of the kernel, based on the rpm documentation, anything that
requires "kernel = 2.6.9" will be satisfied by the default packaging behavior.
Therefore I see no reason why this line, which AFAICT causes nothing but
confusion/harm should remain. Patch attached.


Version-Release number of selected component (if applicable):
kernel-2.6.9-11.EL

How reproducible:
Always

Steps to Reproduce:
1. get on a system whose latest kernel is 2.6.9-11.EL
2. install lvm2-2.02.01-1.3.RHEL4 (which requires kernel >= 2.6.9-24)
3. 
  
Actual results:
The lvm2 package is installed without flagging the unsatisfied dependency

Expected results:
Installation should fail since kernel-2.6.9-11.EL < kernel-2.6.9-24

Additional info:
There is nothing wrong with lvm2's packaging -- the problem is in the kernel
spec file.
Comment 1 David Lehman 2006-05-05 12:53:49 EDT
Created attachment 128667 [details]
remove incorrect explicit "provides: kernel = %{version} from kernel-2.6.spec
Comment 2 RHEL Product and Program Management 2006-09-07 15:18:54 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 RHEL Product and Program Management 2006-09-07 15:18:58 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 6 Jason Baron 2006-12-05 12:16:51 EST
well, i'm wondering why this isn't yet done in Fedora kernels....and i also
don't know how to change to subpackages...so at this point i'm still looking for
more data before i commit it. thanks.
Comment 7 Jason Baron 2006-12-05 13:00:47 EST
well, i'm wondering why this isn't yet done in Fedora kernels....and i also
don't know how to change to subpackages...so at this point i'm still looking for
more data before i commit it. thanks.
Comment 8 Linda Wang 2007-01-18 17:52:31 EST
after talking to KevinA, we came to the conclusion that we should just
document this dependency and not fix either the kernel nor lvm pkg, because
there are still loopholes in implementing the dependencies in these two packages.

Note You need to log in before you can comment on or make changes to this bug.