Bug 190843 - Update to latest version
Summary: Update to latest version
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse-pydev   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Andrew Overholt
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-05-05 17:10 UTC by Ryan Skadberg
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-05 17:48:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ryan Skadberg 2006-05-05 17:10:10 UTC
Let me preface this with I am a complete newbie to Eclipse.  I decided to try it
out for a project I am working on and it worked well, so I am using it more and
more.

The problem is that I had an issue with Eclipse locking up and went to the pydev
site.  I looked at the FAQ and saw:

http://pydev.sourceforge.net/faq.html#ref_8

At the end, it says that there was a bug before 0.9.8.6 that is causing the
issue I am having.    It looks like Fedora is packaged with 0.9.3, so this bug
is still present.

It looks to me like 1.0.6 is out, is there any chance we can get this updated in
rawhide?

I tried to just do it by hand, by recompiling the source rpm, but it looks like
the stuff in the SRPM was from some CVS, which wasn't too specific.

So, I thought I'd file a bug and hope that someone who knows this stuff better
than I could get this upgraded.

Thanks!

Comment 1 Andrew Overholt 2006-05-05 17:48:12 UTC
(In reply to comment #0)
> Let me preface this with I am a complete newbie to Eclipse.  I decided to try it
> out for a project I am working on and it worked well, so I am using it more and
> more.

Cool!

> It looks to me like 1.0.6 is out, is there any chance we can get this updated in
> rawhide?

Unfortunately, no.  Versions after the one we shipped in FC4 (and are still
shipping in FC5) use java 1.5-isms that we can't compile.  People often suggest
using retroweaver but that requires you to be able to compile the 1.5 bytecode
to begin with which we of course can't do.  Yes, we have a 1.5 compiler with ecj
but without the proper class library support in GNU Classpath (libgcj in this
case), we're dead in the water.  We're hoping that this situation (1.5 stuff) is
resolved sometime this year but I don't know if we'll have everything in place
for FC6.

> I tried to just do it by hand, by recompiling the source rpm, but it looks like
> the stuff in the SRPM was from some CVS, which wasn't too specific.

Yeah, the source generation isn't the most straightforward thing.  I'll ask Igor
to put a comment in the specfile regarding how the source was generated.

Perhaps we can pull a specific patch in from the more recent versions of pydev?

Sorry,

Andrew


Note You need to log in before you can comment on or make changes to this bug.