Bug 190856 - Tyan 2895 - SCSI controller does not show up
Tyan 2895 - SCSI controller does not show up
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-05 14:49 EDT by Etienne Clement
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-31 14:08:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Etienne Clement 2006-05-05 14:49:38 EDT
Description of problem:

It is not possible to get the SCSI controller on a Tyan 2895 motherboard to work.

Version-Release number of selected component (if applicable):

How reproducible:

Follow the steps!

Steps to Reproduce:
1. Boot RedHat 4.0 update 2 with acpi=off
2. Do a lspci
3. Notice that the SCSI controller is not listed
  
Actual results:

SCSI controller is not listed.

Expected results:

Should see something like:

61:06.0 SCSI storage controller: LSI Logic / Symbios Logic 53c1030 PCI-X
Fusion-MPT Dual Ultra320 SCSI (rev 07)
61:06.1 SCSI storage controller: LSI Logic / Symbios Logic 53c1030 PCI-X
Fusion-MPT Dual Ultra320 SCSI (rev 07)

Additional info:

I also tried without acpi=off and the machine does not boot. The following
message appears in a loop:

mptbase: Initiating ico0 recovery

I tried with the update 3 kernel with the same results.

I tried the lastest version of the Tyan 2895 BIOS (i.e 1.03)

I also tried it on a HP xw9300 which uses a Tyan 2895 and it worked fine. The
only difference I could see between the two machines is that the HP xw9300 uses
a different BIOS.
Comment 1 Dan Carpenter 2006-05-05 16:01:03 EDT
>>>
I also tried it on a HP xw9300 which uses a Tyan 2895 and it worked fine. The
only difference I could see between the two machines is that the HP xw9300 uses
a different BIOS.
>>>

It sounds like a BIOS issue.  There are known issues with the 1.02 and 1.03 BIOS
with a variety of cards (adaptec, nvidia, the onboard sata controller and
probably a few others).  Could you try the 1.01 BIOS?

The 1.01 BIOS doesn't boot from certain RAID configs but after if it boots then
it generally works.

Comment 2 Etienne Clement 2006-05-08 13:04:46 EDT
Well I finally managed to change the BIOS to 1.01 and it solves the problem.
However, one thing that I forgot to mentionned originally is that with the 1.03
BIOS I was see SCSI controller using Knoppix. The version of Knoppix I used was
running a 2.6.11 kernel. Therefore, the problem seems to be an incopatibility
with the 1.03 BIOS and the RedHat linux kernel.
Comment 3 Dan Carpenter 2006-05-08 13:46:12 EDT
With Linux, you get new versions of the kernel out every month or so and they
all use the BIOS and ACPI information slightly differently.  For example, some
versions of Linux use the MP table to route IRQs, the newer ones use ACPI. 
Older versions of Linux use the e820 information to determine what RAM you have,
newer ones use the SRAT tables.  

BIOS makers just test with Windows normally and so there are often huge gaps and
mistakes that only get discovered in Linux.  It's part of the joy of life.

Comment 4 Etienne Clement 2006-05-08 14:37:10 EDT
If I understand correctly you think that the problem is solely a BIOS issue and
that I would have more chances to get the problem fixed if I submit a bug to Tyan? 
Comment 5 Dan Carpenter 2006-05-08 15:25:40 EDT
Yes.  This is a BIOS bug with Tyan.

Comment 6 Dan Carpenter 2006-08-13 15:53:53 EDT
Actually I think it's a kernel bug after all.  I wrote a patch for it in bug 202130

Comment 7 Etienne Clement 2006-08-14 10:49:40 EDT
Great! I'll try it when I get a chance.

(In reply to comment #6)
> Actually I think it's a kernel bug after all.  I wrote a patch for it in bug
202130
> 
> 


Note You need to log in before you can comment on or make changes to this bug.