Bug 190895 - bzflag locks keyboard
bzflag locks keyboard
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: bzflag (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-05 21:09 EDT by Pedro Matiello
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: f7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-08 07:41:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pedro Matiello 2006-05-05 21:09:39 EDT
Description of problem:
After some time of playing (can be from few minutes to about an hour), bzflag
locks the keyboard. Mouse keeps moving, but clicks are ignored. I can't even
switch to another terminal with CTRL+ALT+Fn or kill X with CTRL+ALT+BACKSPACE.

Version-Release number of selected component (if applicable):
bzflag-2.0.4-3

How reproducible:
Always, if I play enough time.

Steps to Reproduce:
1. Just play
2.
3.
  
Actual results:
Keyboard locks.

Expected results:


Additional info:
Not sure if it's relevant, but I have an ATI card. I'm NOT using ATI proprietary
drivers, but the free driver that comes with fc5.

If some other info is needed, please let me know and I will provide it.
Comment 1 Pedro Matiello 2006-05-06 00:03:00 EDT
I've done some research and it seems to be just a bug in bzflag that makes it
freeze. As bzflag grabs the keyboard, when it freezes the keyboard gets locked
because bzflag is holding it.

I found a way to take the keyboard focus away from bzflag. These lines have to
be added to xorg.conf:

Section "ServerFlags"
        Option "AllowDeactivateGrabs" "true"
EndSection

Then, you can send the keyboard focus to X by hiting CTRL+ALT+Numpad-/. After
that, it's possible to CTRL+ALT+Fn or even ALT+F2 and then kill bzflag.

Maybe these lines shoud be added by default to xorg.conf?
Comment 2 Nils Philippsen 2007-11-07 11:59:13 EST
While this is a feasible workaround, I don't think adding that to the default X
configuration is the right thing to do. Do you still experience these problems
with current Fedora versions (F7 or F8)?
Comment 3 Pedro Matiello 2007-11-07 15:47:56 EST
I haven't tried Fedora 8 yet (I'll download the final release tomorrow), but the
problem seems to be gone in Fedora 7.

Anyway, the xorg fix proposed would work as a workaround for any misbehaving
application that locks input and it has no side effects. I see it as an useful
addition to the default configuration regardless of bzflag being fine now. I
believe it should be considered, but I can live without that. :)
Comment 4 Nils Philippsen 2007-11-08 07:41:40 EST
(In reply to comment #3)

> Anyway, the xorg fix proposed would work as a workaround for any misbehaving
> application that locks input and it has no side effects. I see it as an useful
> addition to the default configuration regardless of bzflag being fine now. I
> believe it should be considered, but I can live without that. :)

The problem is that AllowDeactivateGrabs and AllowClosedownGrabs are potentially
harmful. You and I may know what we do if we activate these, but your uncle and
my aunt surely don't (I can vouch for my aunt here). Bearing that in mind, I
don't see how you could convince the Xorg maintainers to enable this as default.

Note You need to log in before you can comment on or make changes to this bug.