Bug 190936 - weak proxy configuration
weak proxy configuration
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-06 17:32 EDT by Piergiorgio Sartor
Modified: 2014-01-21 17:54 EST (History)
1 user (show)

See Also:
Fixed In Version: fc5-updates
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-18 16:33:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Piergiorgio Sartor 2006-05-06 17:32:18 EDT
Description of problem:
In a PC using a proxy to connect to internet, yum must be configured
properly in order to use the proxy.
This can be done by adding the "proxy" command to yum.conf.
Problem is that, in order to scan all the possible mirrrors, also the
ftp proxy should work, otherwise yum fails, and the ftp proxy cannot
be added to the http proxy in yum.conf (at least I could not find any
way to do it).

Version-Release number of selected component (if applicable):
2.6.0-1

How reproducible:
Always, as far as I could test.

Steps to Reproduce:
1.
Add the command "proxy=..." to yum.conf
2.
Try something like "yum update"
3.
  
Actual results:
yum fails with some error like:

Cannot find a valid baseurl for repo: core
Error: Cannot find a valid baseurl for repo: core

Expected results:
The repository schould be scanned and the update (in this example) occur.

Additional info:
Exporting http_proxy=... and ftp_proxy=... separately works.
So, the problem is either in the documentation, or in the config file.
Comment 1 Seth Vidal 2006-05-06 18:09:23 EDT
try out yum 2.6.1 just released in the updates repository - see if it works for you.
Comment 2 Piergiorgio Sartor 2006-05-08 15:25:52 EDT
I tried just today the yum 2.6.1 and I must say that, while the
problem is not visible anymore, it seems to me that it is just
masked and not really solved.
If I understand correctly, now yum will not gave up when some
ftp mirrot is not found, due to the missing proxy.
I think it would be a better solution to have the possibilty to
define http and ftp proxies separately in yum.conf.
Maybe a TODO item for yum 2.7.0...
Thanks.

Note You need to log in before you can comment on or make changes to this bug.