This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 190961 - YumEx 1.0.0 crashed
YumEx 1.0.0 crashed
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
5
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-07 09:35 EDT by Georg F. Bolz
Modified: 2014-01-21 17:54 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-10 04:08:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Message from YumEx crash (2.00 KB, text/plain)
2006-05-07 09:35 EDT, Georg F. Bolz
no flags Details
depsolve patch (1.42 KB, patch)
2006-05-11 16:27 EDT, Dawid Zamirski
no flags Details | Diff

  None (edit)
Description Georg F. Bolz 2006-05-07 09:35:25 EDT
Description of problem: 
YumEx crashed when processing a RPM file (reported to be missing)  

Version-Release number of selected component (if applicable):
Group        : Applications/System
Source       : yumex-1.0.0-1.0.fc5.src.rpm
Build Time   : Wed May  3 13:15:18 2006
Install Time : Sun May  7 02:58:35 2006
License      : GPL

Group        : System Environment/Base
Source       : yum-2.6.1-0.fc5.src.rpm
Build Time   : Wed Apr 26 21:29:10 2006
Install Time : Sun May  7 02:32:23 2006
License      : GPL

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
error message asked me to provide a bug report - herewith, I do. 

Expected results:


Additional info: 
see error message file included
Comment 1 Georg F. Bolz 2006-05-07 09:35:26 EDT
Created attachment 128708 [details]
Message from YumEx crash
Comment 2 Seth Vidal 2006-05-07 09:57:08 EDT
assiging to yumex
Comment 3 Tim Lauridsen 2006-05-08 02:52:59 EDT
I look like a problem downloading a rpm header, i will take a deeper look.
I dont think you will get this error is you retry, but it should be handled in a
better way by yumex.
Comment 4 Dawid Zamirski 2006-05-09 13:39:53 EDT
This isn't necessarily yumex bug. Yumex received return code 2 from
buildTransaction() which means that everythig went good, but there is a call to
downloadHeader() in resolveDeps (belonging to yum) which throws an exception on
failure without returnig error code. Yum should handle downloadHeader() with
try/except and return relevant error code to calling functions. We could
workaround this in Yumex but I think it would be better to improve error
handling in yum, so we can rely more on error codes in the future.
Comment 5 Seth Vidal 2006-05-11 14:39:45 EDT
Dawid, can you point to where in the code you think this should be fixed?
Comment 6 Dawid Zamirski 2006-05-11 16:27:37 EDT
Created attachment 128914 [details]
depsolve patch

I have attached patch against depsolve.py in yum 2.6.1 that would pass the
error code up to calling functions. It's a rough patch, not a final solution,
since I didn't test it (I'm at work right now) but it should show what I meant
:-)
Comment 7 Tim Lauridsen 2006-08-10 04:08:15 EDT
I have added added a exception handler in the process_one method, so this kind
of errors get catched in the same ways as when doing a normal package processing.
I dont solve the problem but makes yumex behave better when this kind of error
occours.

Note You need to log in before you can comment on or make changes to this bug.