Bug 191013 - (Fradyak) Error opening add/remove programs and software update
Error opening add/remove programs and software update
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-07 23:35 EDT by David Frady
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-08 11:03:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
folowing some steps to hopefully install madwifi (1.92 KB, application/octet-stream)
2006-05-07 23:35 EDT, David Frady
no flags Details

  None (edit)
Description David Frady 2006-05-07 23:35:53 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. http://madwifi.org/wiki/UserDocs/Distro/RedHat Folow Fedora 5 directions to..
2. yum --enablerepo atrpms install madwifi
3. Then atempt to open software updater or add/remove programs
  
Actual results:
error opening add/remove programs or software update

Expected results:
install component for instaltion of madwifi

Additional info:
Comment 1 David Frady 2006-05-07 23:35:53 EDT
Created attachment 128726 [details]
folowing some steps to hopefully install madwifi
Comment 2 David Frady 2006-05-07 23:38:16 EDT
Component: Software Manager
Summary: TB4426d5a1 ConfigParser.py:490:_read:ParsingError: File contains
parsing errors: ///etc/yum.repos.d/atrpms.repo
	[line  5]: 'against enabling atrpms for standard yum usage.\n'

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 363, in ?
    main()
  File "/usr/sbin/pirut", line 358, in main
    pm = PackageManager()
  File "/usr/sbin/pirut", line 56, in __init__
    GraphicalYumBase.__init__(self, False)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 122, in __init__
    self.doConfigSetup()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 104, in
doConfigSetup
    self.getReposFromConfig()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 135, in
getReposFromConfig
    parser.read(files)
  File "/usr/lib/python2.4/site-packages/yum/parser.py", line 225, in read
    IncludingConfigParser.read(self,filename)
  File "/usr/lib/python2.4/site-packages/yum/parser.py", line 126, in read
    ConfigParser.read(self,filename)
  File "/usr/lib/python2.4/ConfigParser.py", line 267, in read
    self._read(fp, filename)
  File "/usr/lib/python2.4/ConfigParser.py", line 490, in _read
    raise e
ParsingError: File contains parsing errors: ///etc/yum.repos.d/atrpms.repo
	[line  5]: 'against enabling atrpms for standard yum usage.\n'

Local variables in innermost frame:
sectname: atrpms
cursect: {'__name__': 'atrpms', 'enabled': '0', 'name': 'Fedora Core $releasever
- $basearch - ATrpms', 'baseurl':
'http://dl.atrpms.net/fc$releasever-$basearch/atrpms/stable'}
e: File contains parsing errors: ///etc/yum.repos.d/atrpms.repo
	[line  5]: 'against enabling atrpms for standard yum usage.\n'
fpname: ///etc/yum.repos.d/atrpms.repo
vi: =
mo: <_sre.SRE_Match object at 0xb7a372a0>
optname: enabled
fp: <open file '///etc/yum.repos.d/atrpms.repo', mode 'r' at 0xb7a13f98>
lineno: 7
line: 
self: <yum.parser.IncludedDirConfigParser instance at 0xb7a3038c>
optval: 0
Comment 3 Jeremy Katz 2006-05-08 11:03:41 EDT
Your yum repo file is invalid (it looks like it might have an unexpected newline
in a comment or something).  Please contact the provider of that file.
Comment 4 Jeremy Katz 2006-05-08 13:23:58 EDT
Also, we've added handling to catch this error and give a nicer dialog rather
than a traceback for the future (yum > 2.6.1 and pirut > 1.0.2)

Note You need to log in before you can comment on or make changes to this bug.