Bug 191057 - Hal does not respect volume.policy.mount_option.*
Hal does not respect volume.policy.mount_option.*
Status: CLOSED DUPLICATE of bug 188224
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
Depends On:
  Show dependency treegraph
Reported: 2006-05-08 11:59 EDT by Erwan LE PENNEC
Modified: 2013-03-13 00:50 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-05-08 13:07:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Modified storage method (the vfat section only has been modified) (8.42 KB, application/octet-stream)
2006-05-08 11:59 EDT, Erwan LE PENNEC
no flags Details

  None (edit)
Description Erwan LE PENNEC 2006-05-08 11:59:30 EDT
Description of problem:
Hal seems to not use the volume.policy.mount_option provided in the fdi files
when it mounts the volume although the key appears with hal-device-manager.

Version-Release number of selected component (if applicable): 
FC5 uptodate

How reproducible:
Using the attached fdi file does not produce the intended result i.e. mounting
all the vfat drive with the options utf8 and iocharset=iso8859-1.

Steps to Reproduce:
1.replace the fdi file with the attached one (/usr/share/hal/fdi//policy/10osvendor)
2. plug a usb drive
3. look at the mount option in /etc/mtab
Actual results:
/dev/sda2 /media/disk vfat rw,noexec,nosuid,nodev,shortname=winnt,uid=500 0 0 

Expected results:
/dev/sda2 /media/disk vfat
rw,noexec,nosuid,nodev,shortname=winnt,uid=500,utf8,isocharset=iso8859-1 0 0

Additional info:
Seems to be similar to the Bugzilla Bug 188091, although I do not see any
security reason for this behaviour.

I used a similar hack in a previous version (FC4+nrpms) with success but I'm not
100% sure that the syntax is correct!
Comment 1 Erwan LE PENNEC 2006-05-08 11:59:31 EDT
Created attachment 128748 [details]
Modified storage method (the vfat section only has been modified)
Comment 2 John (J5) Palmieri 2006-05-08 13:07:03 EDT

*** This bug has been marked as a duplicate of 188224 ***

Note You need to log in before you can comment on or make changes to this bug.