Bug 191068 - sk98lin driver can't cope with Marvell 88E8001 GbE controller
sk98lin driver can't cope with Marvell 88E8001 GbE controller
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-08 13:40 EDT by Randy Zagar
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-12 11:05:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Force sk98lin to ignore VPD checksum errors (642 bytes, patch)
2006-05-09 18:30 EDT, Randy Zagar
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 136158 None None None Never

  None (edit)
Description Randy Zagar 2006-05-08 13:40:32 EDT
Description of problem:
I have installed RHEL-4 Update 3 on an Shuttle-SB83G5 , which has the Marvell
88E8001 gigabit ethernet chip in it.  When inserting the sk98lin module, the
kernel gives the following error every second or two:

May  8 10:59:25 localhost kernel: eth0: -- ERROR --
May  8 10:59:25 localhost kernel:         Class:  internal Software error
May  8 10:59:25 localhost kernel:         Nr:  0x19e
May  8 10:59:25 localhost kernel:         Msg:  Vpd: Cannot read VPD keys

Version-Release number of selected component (if applicable):
2.6.9-34.EL

How reproducible:
always

Steps to Reproduce:
1. Install RHEL-4.U3 on hardware with Marvell 88E8001 hardware...
2. Look at the system logs
  
Actual results:
May  8 10:59:25 localhost kernel: eth0: -- ERROR --
May  8 10:59:25 localhost kernel:         Class:  internal Software error
May  8 10:59:25 localhost kernel:         Nr:  0x19e
May  8 10:59:25 localhost kernel:         Msg:  Vpd: Cannot read VPD keys

Expected results:
no errors

Additional info:
This is also being addressed in Fedora Core as bugzilla #136158
Comment 1 Randy Zagar 2006-05-09 18:30:58 EDT
Created attachment 128822 [details]
Force sk98lin to ignore VPD checksum errors

Marvell is publishing a 2.6 kernel patch for the sk98lin v2.6 driver.  The only
change they recommend is to comment out the section of code that checks for
Vital Product Data (VPD) checksum errors...

The sk98lin driver in RHEL-4.U3 is significantly older, but the attached patch
makes the same (narrowly-focused) change to the current 2.6.9-34.EL kernel.
Comment 2 John W. Linville 2006-05-16 14:16:56 EDT
Please try the skge driver in the kernels here: 
 
   http://people.redhat.com/linville/kernels/rhel4/ 
 
I would prefer not to take any patches for sk98lin if at all possible. 
Comment 3 Randy Zagar 2006-05-22 23:48:39 EDT
I understand.  But my perspective is that of a conservative sys-admin, not a
vendor or a kernel developer.  If I have to diverge from a stock released
kernel, I want to do so minimally.  That way I stay very close to your
well-tested path.
Comment 4 John W. Linville 2006-05-23 15:41:06 EDT
OK...then please try the skge driver in U4 when it becomes available?
Comment 5 Randy Zagar 2006-05-24 12:33:54 EDT
Yes.  Definitely.
Is there a tentative date for U4 yet?
Comment 6 John W. Linville 2006-08-14 11:09:07 EDT
U4 should be out now...can you try the skge driver?  thanks!
Comment 7 John W. Linville 2006-10-12 11:05:28 EDT
Closed due to lack of response.  Please reopen (if appropriate) when the 
requested information becomes available...thanks!

Note You need to log in before you can comment on or make changes to this bug.