Bug 191076 - Unable to record sound by microphone with SB Live
Unable to record sound by microphone with SB Live
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
Depends On:
  Show dependency treegraph
Reported: 2006-05-08 14:33 EDT by Marcin Zajaczkowski
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-08-08 07:28:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Marcin Zajaczkowski 2006-05-08 14:33:12 EDT
Description of problem:

It's impossible to record any sound from a microphone. I've tried with autacity
(OSS), rawrec (OSS), arecord (ALSA) and kiax/iaxclient (Voip client) (OSS). The
only thing I was able to record was sound from "Wave" channel (when I chose to
record from it). I have Sound Blaster Live 5.1.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Try to record sound with any program
Actual results:
Nothing is recorded.

Expected results:
Voice (detected by microphone) is recorded.

Additional info:
Problem seems to be fixed in alsa-lib 1.0.11 final version (1.0.11-2) available
from: http://people.redhat.com/stransky/alsa/index.html
Unfortunately there is sound settings restoration broken in alsa-utils-1.0.11-2
available from that location (it's needed to use 1.0.11-4.rc2 from FC5, but it's
an another bug).
More info: http://forums.fedoraforum.org/showthread.php?t=105564

It's quite serious for people who use computer to make VoIP calls.
Comment 1 Marcin Zajaczkowski 2006-05-08 14:57:08 EDT
It's related with https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=167522 (I
didn't find it earlier), but it's quite old bug and could be fixed in FC5.

Btw, why alsa-lib 1.0.11 final isn't available in FC5 (even in a "Raw Hide")?
Comment 2 Martin Stransky 2006-05-15 10:56:59 EDT
You can use 1.0.11 final drivers and alsa-lib/utils from FC5, alsa packages on
my site are for debugging only. ALSA drivers in kernel depends on kernel
so, do alsa drivers 1.0.11 work for you?
Comment 3 Marcin Zajaczkowski 2006-05-15 16:05:36 EDT
After installation proces of FC5 I upgraded kernel package to 2.6.16-1.2111_FC5
(and made other available updates). The sound wasn't recorded. Later I upgraded
alsa-lib to 1.0.11-2 and alsa-utils to 1.0.11-2 (from your site) and I was able
to record sound (drivers from kernel remain unchanged).

Due to problem with restoration of sound settings (wasn't loaded at startup, but
"/usr/sbin/alsactl restore 0" called by hand worked) I had to downgrade
alsa-utils to 1.0.11-4 (from Fedora Updates).

After that operations I can record sound using my microphone and sound settings
restoration works properly.
Comment 4 Vladimir Kotal 2006-07-06 19:41:35 EDT
Oh well, I hoped that bug 167522 will be fixed in FC5 but it is not. I am seeing
the same problem with 

[techie@erazim ~]$ cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.11rc4 (Wed Mar 22 10:27:24
2006 UTC).
[techie@erazim ~]$ rpm -q kernel
[techie@erazim ~]$

Any estimations on when 1.0.11 final version (with working sound recording) will
hit FC5 updates ?
Comment 5 Thomas Antony 2006-07-07 13:57:18 EDT
I did have very similiar problems with my SB Live Player 5.1 [SB0060].
When i speak into the microphone there was no sound recorded, but i did hear my
voice through the speakers.
I had to open alsamixer and set in capture mic as caputure device (the default
was cd?!?!?) and turn capture and ac97 louder. After this changes sound
recording worked again, but i still did hear myself through the speaker. After i
set in Playback AC97 to 0, everything worked as it should.
When i change something in the Gnome volume control under recording, sound
recording is broken again and i need to change the setting another time with
I can reproduce this bug with every fresh install since FC3.
Comment 6 Vladimir Kotal 2006-07-08 10:49:30 EDT
This looks like another long "unable to record sound with SB5.1 on FC" thread
has been started. I have tried to select the mic via alsamixer. (I have two
choices - Mic1 and Mic2, none of them worked) 

I am not able to hear myself in the speakers no matter what I do. I will try to
use Martin Stransky's alsa-lib and see if it works.
Comment 7 Vladimir Kotal 2006-07-08 10:57:21 EDT
I have tried to rpmbuild alsa-utils which went fine, but alsa-lib gave me this
weird error:

[root@erazim alsa-problems]#  rpmbuild --rebuild alsa-lib-1.0.11-2.src.rpm
Installing alsa-lib-1.0.11-2.src.rpm
warning: user komat does not exist - using root
warning: group komat does not exist - using root
warning: user komat does not exist - using root
warning: group komat does not exist - using root
warning: user komat does not exist - using root
warning: group komat does not exist - using root
warning: user komat does not exist - using root
warning: group komat does not exist - using root
error: Failed build dependencies:
        doxygen is needed by alsa-lib-1.0.11-2.i386

Why alsa-lib needs doxygen for building ? Also, if it needs special user, it
should create it.
Comment 8 Martin Stransky 2006-08-08 07:27:55 EDT
alsa-lib contains a documantation generated by doxygen during compilation. You
don't have to care about user, root is fine...
Comment 9 Vladimir Kotal 2006-08-08 17:05:13 EDT
alsa-lib package should do really better and use root straight ahead. using
unknown user looks at least suspicious.
Comment 10 Vladimir Kotal 2006-08-08 17:07:13 EDT
which version of kernel package contains the fix ? when it will be released
outside rawhide ?
Comment 11 Martin Stransky 2006-08-09 02:46:25 EDT
I'm afraid there isn't any kernel with 1.0.11 driver available for FC5...
Comment 12 Vladimir Kotal 2006-08-09 03:55:20 EDT
So the Resolution field should be set to NEXTVERSION and not RAWHIDE. I'm
getting feeling of deja-vu. This means that for 2 whole releases of Fedora sound
recording with SB Live 5.1 is not possible.
Comment 13 Vladimir Kotal 2006-10-21 05:08:14 EDT
Hah, there is kernel with 1.0.12 driver for FC5 !

[root@erazim Notes]# uname -a
Linux erazim.local.lab.devnull.cz 2.6.18-1.2200.fc5 #1 Sat Oct 14 16:59:26 EDT
2006 i686 athlon i386 GNU/Linux
[root@erazim Notes]# cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.12rc1 (Thu Jun 22 13:55:50
2006 UTC).

but the sound recording still does not work. Going to submit another bug.
Comment 14 Vladimir Kotal 2006-11-18 14:43:46 EST
In case someone finds this bug: it is very important to unmute AC97 channel.
(works on FC6)

Note You need to log in before you can comment on or make changes to this bug.