Bug 191090 - Support http 302 redirect requests in rhnlib
Support http 302 redirect requests in rhnlib
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bret McMillan
Beth Nackashi
:
Depends On:
Blocks: 179644 181409
  Show dependency treegraph
 
Reported: 2006-05-08 15:29 EDT by James Bowes
Modified: 2013-01-10 04:49 EST (History)
2 users (show)

See Also:
Fixed In Version: RHEA-2006-0490
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-02 00:34:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Fanny Augustin 2006-05-09 15:23:54 EDT
This bug has been fixed in this release
Comment 6 Beth Nackashi 2006-06-02 12:23:18 EDT
From 175153:

Right now, rhnlib shouldn't behave any differently than it currently does.  The
only difference is if, at some point in the future, the backend issues a 302
redirect, the newer rhnlib will follow it.

Unfortunately, there is not currently a clear path to having RHN Hosted issuing
302 requests until certain contract/etc issues are worked out w/ the 3rd-party
provider.

A decision has been made to leave the code in for 3u8/4u4.  This was deemed
especially important as it's not certain there will be a 3u9.

Normal up2date usage should sufficiently regression-test the new rhnlib
codebase, and once we understand what 3rd-party provider we'll be going with, we
will either be able to:
a)  use the existing implementation, test it, and hopefully just turn on
everyone that consumed the 3u8/4u4 rhnlib and make them all happy, or
b)  have to change the implementation due to 3rd-party provider requirements. 
If this happens, we'd have to errata rhnlib anyway, so we simply bump the
version of the client capability and only issue redirects to the known good ones.

I hope this explanation is sufficient for qa's purposes, please let me know if not.
Comment 7 Beth Nackashi 2006-06-02 12:25:03 EDT
part of the larger up2date test effort for rhel4 u4
Comment 9 Red Hat Bugzilla 2006-08-02 00:35:04 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2006-0490.html

Note You need to log in before you can comment on or make changes to this bug.