Bug 191101 - hal %postun has a syntax error
hal %postun has a syntax error
Status: CLOSED DUPLICATE of bug 190947
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-08 17:15 EDT by Nalin Dahyabhai
Modified: 2013-03-13 00:50 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-16 12:32:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nalin Dahyabhai 2006-05-08 17:15:49 EDT
Description of problem:
Here's the hal %postun scriptlet:
   /sbin/ldconfig
   #if [ "$1" -ge "1" ]; then
   #  service haldaemon condrestart > /dev/null 2>&1
   z#fi

That last "z" shouldn't be there.

Version-Release number of selected component (if applicable):
0.5.7-5

How reproducible:
Always.

Steps to Reproduce:
1.Upgrade to a newer version of hal.
  
Actual results:
/var/tmp/rpm-tmp.85178: line 4: z#fi: command not found
%postun(hal-0.5.7-5.i386) scriptlet failed, exit status 127

Expected results:
(nothing)
Comment 1 John (J5) Palmieri 2006-05-16 12:32:26 EDT
Search the archives before you post a bug my friend :-)

*** This bug has been marked as a duplicate of 190947 ***
Comment 2 John (J5) Palmieri 2006-05-16 12:34:37 EDT
doh, sorry nalin, thought it was a new bug and was being cheaky ;-)

Note You need to log in before you can comment on or make changes to this bug.