Bug 191131 - perl-IO-Tty: update to 1.03
perl-IO-Tty: update to 1.03
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: perl-IO-Tty (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-08 22:33 EDT by Jose Pedro Oliveira
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-09 14:49:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jose Pedro Oliveira 2006-05-08 22:33:02 EDT
Ville,

Could you update perl-IO-Tty to version 1.03 in the next days?
I'm planning to submit for reviewing the Expect and Test::Expect modules in the
next days (and the latest version of Expect requires IO::Tty 1.03).

The update appears to be simple based on the differences to the previous version:
http://search.cpan.org/diff?from=IO-Tty-1.02&to=IO-Tty-1.03

TIA,
jpo
Comment 1 Ville Skyttä 2006-05-09 11:14:27 EDT
Sure, but as you're packaging something that actually uses perl-IO-Tty, would
you be interested in maintaining it?  The only thing I'm currently using it for
is the perl-IPC-Run testsuite (BR only), and I'm not using perl-IPC-Run either
much these days...

Just go ahead with owners.list if you want maintainership (ditto perl-IPC-Run);
otherwise, let me know and I'll push the update.
Comment 2 Jose Pedro Oliveira 2006-05-09 13:34:05 EDT
(In reply to comment #1)
> Sure, but as you're packaging something that actually uses perl-IO-Tty, would
> you be interested in maintaining it?  The only thing I'm currently using it for
> is the perl-IPC-Run testsuite (BR only), and I'm not using perl-IPC-Run either
> much these days...
> 
> Just go ahead with owners.list if you want maintainership (ditto perl-IPC-Run);
> otherwise, let me know and I'll push the update.

Ok. I will take maintainership of IO::Tty for now. Changing owners file in a
couple of minutes.

I finally had a couple of free hours to starting reading "Perl Testing: A
Developers Notebook" and I will try to submit most of the test modules it
mentions.

jpo
Comment 3 Jose Pedro Oliveira 2006-05-09 14:49:26 EDT
Updated and built for FC-4, FC-5, and devel.

Note You need to log in before you can comment on or make changes to this bug.