Bug 191146 - Activation Key Config Auto Deploy fails with "Illegal Function Call Attempted"
Activation Key Config Auto Deploy fails with "Illegal Function Call Attempted"
Status: CLOSED DEFERRED
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Configuration Management (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Todd Sanders
Brandon Perkins
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-09 02:32 EDT by Roel Gloudemans
Modified: 2009-08-21 23:03 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-21 23:03:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roel Gloudemans 2006-05-09 02:32:29 EDT
Description of problem:

When bootstrapping the system we have a config channel included in one of the
activation keys. This results in 3 scheduled activities:
1) Activation Key Config File Deployment
2) Activation Key Package Auto-Install
3) Activation Key Config Auto-Deploy 

This last action structurally fails with "Illegal function call attempted". I
can find nothing in the log files about which function call it might be. But if
the action is rescheduled, it succeeds and the config files are deployed.

Version-Release number of selected component (if applicable):
Satellite 4.0.6 on RHAS3_U6. Client is RHAS3_U6

How reproducible:
Always

Steps to Reproduce:
1. Bootstrap
2.
3.
  
Actual results:
Config files are not deployed

Expected results:
Config files deployed
Comment 1 Roel Gloudemans 2006-06-21 01:51:28 EDT
This is solved in Update 7.
Comment 2 Kyle Gonzales 2006-08-03 12:21:54 EDT
I'm seeing this issue on a RHEL3U5 system, that has the most recent versions of
up2date, rpm, rhnlib, and all dependencies installed by the activation key.

I can, immediately after the activation is complete, run "rhncfg-client get" and
get the files.  I can also schedule the deployment of the configs in the GUI,
then run rhn_check on the system.  That works too.

It just does not work during the activation of the system.

This is in RHN410.
Comment 3 Red Hat Bugzilla 2007-04-11 20:40:30 EDT
User bnackash@redhat.com's account has been closed
Comment 4 Red Hat Bugzilla 2007-05-03 01:39:42 EDT
User wregglej@redhat.com's account has been closed
Comment 6 Clifford Perry 2009-08-21 23:03:35 EDT
seems to be fixed. Closing out. Please open a support ticket if further assistance is needed. 

Cliff

Note You need to log in before you can comment on or make changes to this bug.