Bug 191153 - "xulrunner" directories do not match the internal version
Summary: "xulrunner" directories do not match the internal version
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xulrunner   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Marco Pesenti Gritti
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-05-09 09:42 UTC by Joachim Frieben
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-09 14:42:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joachim Frieben 2006-05-09 09:42:35 UTC
Description of problem:
When trying to build "epiphany" against "xulrunner", "configure"
aborts due to wrong versioning.

Version-Release number of selected component (if applicable):
xulrunner-1.8.0.cvs20060505-1

How reproducible:
Always.

Steps to Reproduce:
1. Rebuild "epiphany" adding "--with-gecko=xulrunner".
  
Actual results:
The "configure" aborts complaing:
"configure: error: This program needs a gtk 2 gecko build"

Expected results:
The "configure" script should have completed successfully.

Additional info:
Inspection of "config.log" reveals, that "configure" uses
"/usr/include/xulrunner-1.8.0.4" and -not- the existing
"/usr/include/xulrunner-1.8.0.cvs20060505" etc.
After adding additional symlinks to "/usr/include/xulrunner-1.8.0.4"
etc., the "configure" script completes successfully. It might thus
be better to choose "1.8.0.4" as package version instead of
"1.8.0.cvs20060505" or correct the directories directly.

Comment 1 Marco Pesenti Gritti 2006-05-09 14:42:05 UTC
The xulrunner package is not yet ready for rawhide and it was shipped there by
mistake. I removed it now.

Though I already fixed this in the package we use for olpc, and the fix will be
in rawhide when we actually ship it.


Note You need to log in before you can comment on or make changes to this bug.